Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22508 closed defect (fixed)

Assertion failure in rotate_x509_certificate_callback()

Reported by: dgoulet Owned by:
Priority: Very High Milestone: Tor: 0.3.0.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: client regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Surely related to #22460.

Normal tor client (not a relay) with version 0.3.1.2-alpha-dev (git-5343d2b03c8158fc). Got this two hours after it started:

Jun 06 09:06:02.000 [warn] Can't get my x509 link cert.
Jun 06 09:06:02.000 [err] Unable to update Ed25519->TLS link certificate for new TLS context.
Jun 06 09:06:02.000 [err] tor_assertion_failed_(): Bug: src/or/main.c:1611: rotate_x509_certificate_callback: Assertion 0 failed; aborting. (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug: Assertion 0 failed in rotate_x509_certificate_callback at src/or/main.c:1611. Stack trace: (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     tor(log_backtrace+0x44) [0x557794125024] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     tor(tor_assertion_failed_+0x8d) [0x55779413dfbd] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     tor(+0x4ac00) [0x557794004c00] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     tor(+0x69590) [0x557794023590] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x6a0) [0x7ff066d47420] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     tor(do_main_loop+0x245) [0x557794008345] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     tor(tor_main+0x1c35) [0x55779400bd45] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     tor(main+0x19) [0x557794003bd9] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1) [0x7ff065a573f1] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)
Jun 06 09:06:02.000 [err] Bug:     tor(_start+0x2a) [0x557794003c2a] (on Tor 0.3.1.2-alpha-dev 5343d2b03c8158fc)

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by nickm

Likely fix in 4ed0f0d62f760f (on maint-0.3.0).

comment:2 Changed 2 years ago by nickm

Milestone: Tor: 0.3.1.x-finalTor: 0.3.0.x-final
Resolution: fixed
Status: newclosed

Please reopen if it comes back again?

comment:3 Changed 2 years ago by nickm

Looks like my fix broke unit tests. committed 68c3df69dec4b2 to try to solve everything.

Note: See TracTickets for help on using tickets.