Opened 2 years ago

Closed 14 months ago

#22525 closed defect (duplicate)

content policy filter does not handle relative Locations

Reported by: mcs Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-torbutton, TorBrowserTeam201804, ff60-esr-will-have
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is a spinoff from #21627.

If you visit a page that returns a Location header whose value is a relative URL, the following appears on the browser console:

NS_ERROR_MALFORMED_URI: Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIIOService.newURI] content-policy.js:157

An URL that demonstrates the problem is http://httpstat.us/no-such-page

Child Tickets

Change History (12)

comment:1 Changed 2 years ago by gk

Keywords: TorBrowserTeam201707 added; TorBrowserTeam201706 removed

Moving Tickets to July 2017.

comment:2 Changed 2 years ago by gk

Keywords: TorBrowserTeam201708 added; TorBrowserTeam201707 removed

Moving our Tickets to August.

comment:3 Changed 2 years ago by gk

Keywords: TorBrowserTeam201709 added; TorBrowserTeam201708 removed

Items for September 2017.

comment:4 Changed 23 months ago by gk

Keywords: TorBrowserTeam201710 added; TorBrowserTeam201709 removed

Items for October 2017

comment:5 Changed 22 months ago by gk

Keywords: TorBrowserTeam201711 added; TorBrowserTeam201710 removed

Moving tickets over to November.

comment:6 Changed 21 months ago by gk

Keywords: TorBrowserTeam201712 added; TorBrowserTeam201711 removed

Moving tickets to December 2017, for realz.

comment:7 Changed 20 months ago by gk

Keywords: TorBrowserTeam201801 added; TorBrowserTeam201712 removed

Moving tickets to 2018.

comment:8 Changed 19 months ago by gk

Keywords: TorBrowserTeam201802 added; TorBrowserTeam201801 removed

Moving tickets to Feb

comment:9 Changed 18 months ago by gk

Keywords: TorBrowserTeam201803 added; TorBrowserTeam201802 removed

Adding to our March plate.

comment:10 Changed 17 months ago by gk

Keywords: TorBrowserTeam201804 added; TorBrowserTeam201803 removed

Moving our tickets to April.

comment:11 Changed 16 months ago by gk

Keywords: ff60-esr-will-have added

comment:12 Changed 14 months ago by gk

Resolution: duplicate
Status: newclosed

This still happens with an esr60-based Tor Browser, fwiw. I think we should dupe this over to #26189 as that bug will take care of that.

Note: See TracTickets for help on using tickets.