Opened 6 months ago

Closed 5 months ago

#22535 closed defect (fixed)

searching from about:tor brings me to duckduckgo but my query is discarded

Reported by: arma Owned by: mcs
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff52-esr, tbb-e10s, tbb-7.0-issues, tbb-regression, tbb-usability, TorBrowserTeam201706
Cc: mcs, brade, tbb-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Go to about:tor and in the text box in the middle of the window, type foo and then either hit enter or click the magnifying glass.

It brings me to duckduckgo, but it doesn't carry the search query along with it -- I have to do my search query again once I'm at duckduckgo.

Things work fine from a blank tab, or from the little search box in the upper right.

Child Tickets

Change History (7)

comment:1 Changed 6 months ago by gk

Cc: mcs brade added
Keywords: tbb-usability added

comment:2 Changed 6 months ago by cypherpunks

Keywords: ff52-esr tbb-e10s tbb-7.0-issues tbb-regression added

comment:3 Changed 6 months ago by mcs

It seems that this problem is occurs because about:tor is handled by the chrome process but POST data is lost when the tab is transitioned to the content process (which is why this is an e10s-related issue). See: https://bugzilla.mozilla.org/show_bug.cgi?id=1344465#c6

Absent a fix for that Firefox bug, this problem should disappear if we fix #18913 (and now I think I understand the meaning of ticket:18913#comment:4).

comment:4 Changed 6 months ago by cypherpunks

\o/

comment:5 Changed 6 months ago by mcs

Cc: tbb-team added
Keywords: TorBrowserTeam201706 added

comment:6 Changed 6 months ago by mcs

Owner: changed from tbb-team to mcs
Status: newassigned

comment:7 Changed 5 months ago by gk

Resolution: fixed
Status: assignedclosed

Fixed on master with commit 32f9cf56c89ccd2e24924975dc5515e4198d28c3.

Note: See TracTickets for help on using tickets.