Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22540 closed defect (not a bug)

Some preferences are reset when browser is closed (even those in user.js)

Reported by: nido Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: brade, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am using Tor Browser without Tor as described here: https://www.whonix.org/wiki/Tor_Browser_without_Tor

Until the 7.0 update, these custom preferences could be set (in about:config or in user.js in the profile.default directory) and would persist when Tor Browser was closed and opened again:

// Disable proxying
user_pref("network.proxy.socks_remote_dns", false);
user_pref("network.proxy.type", 0);
// Disable Tor service
user_pref("extensions.torlauncher.start_tor", false);

Since the 7.0 update, only the extensions.torlauncher.start_tor setting persists. The others are reset when Tor Browser is closed, in both Linux and Windows. Even setting them in user.js has no effect; they need to be set manually each time Tor Browser is started. (At least they are applied at once so that using Tor Browser without Tor is possible.)

How can they be made persistent?

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by mcs

Cc: brade mcs added
Status: newneeds_information

In Tor Browser 7.0, the Tor Launcher and Torbutton extensions work together to make it more difficult for people to accidentally disable Tor. Please try setting the TOR_TRANSPROXY environment variable before starting Tor Browser, or disable Tor Launcher extension. Then let us know if one of those solutions resolves this issue for you.

comment:2 Changed 2 years ago by nido

Resolution: not a bug
Status: needs_informationclosed

Setting the preferences (in about:config or with user.js) and disabling Tor Launcher seems to resolve the issue. Thanks!

Tor Browser in Linux (not in Windows) now opens with two "About Tor" home pages, but this may be unrelated.

Last edited 2 years ago by nido (previous) (diff)

comment:3 in reply to:  2 Changed 2 years ago by gk

Replying to nido:

Setting the preferences (in about:config or with user.js) and disabling Tor Launcher seems to resolve the issue. Thanks!

You are welcome.

Tor Browser in Linux (not in Windows) now opens with two "About Tor" home pages, but this may be unrelated.

Could you open a new ticket in our bug tracker with steps to reproduce the issue?

Note: See TracTickets for help on using tickets.