Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22541 closed enhancement (wontfix)

Support for Tor Browser without Tor?

Reported by: nido Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Even without Tor, Tor Browser offers better protection from online tracking than Firefox, Google Chrome/Chromium or Microsoft Edge, especially against fingerprinting, right?

It is was (see #5236) easy to disable Tor in Tor Browser so as to use it as the default clearnet browser, as...

What would you think about releasing and/or supporting a version of Tor Browser without Tor? Why would this not be a good idea?

Child Tickets

Change History (9)

comment:1 Changed 2 years ago by nido

Sorry, I meant to refer to ticket #22540.

comment:2 Changed 2 years ago by gk

Resolution: worksforme
Status: newclosed

Seems this is not a bug either (after #22540 turned out to be not a bug)? If I am wrong please reopen and provide more information about what exactly is missing but has been available previously.

comment:3 Changed 2 years ago by nido

Resolution: worksforme
Status: closedreopened

It isn't a bug. Thus I marked it as an enhancement and wrote at the end:

"What would you think about releasing and/or supporting a version of Tor Browser without Tor? Why would this not be a good idea?"

I was hoping to get some input from developers. I thought the bug tracker would be useful for that. If it's not, change its status to closed again.

(I'd edit the description if I could.)

comment:4 Changed 2 years ago by mcs

This would not be a good idea because we don't want the average person to download something named "Tor Browser" and later learn that it does not use the Tor Network.

Using Tor Browser without Tor is something we can support for advanced users, but in my opinion it would be dangerous to provide such a browser to most users. And I don't think we have enough developers working on Tor Browser to support a rebranded fork (not named "Tor Browser") although someone else could start such a project.

comment:5 Changed 2 years ago by nido

Could someone point me to which files I would need to edit to rebrand Tor Browser?

Do any of you have any thoughts about how its security and privacy features compare to the major browsers when it's used without Tor? Would you use it (without Tor) instead of Chrome/Chromium/Firefox/Brave/...? Why (not)?

Last edited 2 years ago by nido (previous) (diff)

comment:6 Changed 2 years ago by cypherpunks

There could always be someone who would create a small script that would copy an existing TorBrowser and make the necessary changes so that it accesses the clear and then rename it. But I don't think this should be distributed by the Tor Project itself as argued in #comment:4 .

comment:7 Changed 2 years ago by gk

Resolution: wontfix
Status: reopenedclosed

FWIW: We still have plans to help other interested parties (like VPN companies) to ship a browser with all the privacy/security features Tor Browser has but without tor. But we won't ship it ourselves.

Last edited 2 years ago by gk (previous) (diff)

comment:8 Changed 2 years ago by gk

(If "support" is meant to be merging patches if those other vendors/interested parties showed up, then, yes, we would do that.)

comment:9 Changed 2 years ago by nido

Ok, that's good to know.

In your opinion, how does Tor Browser without Tor compare to Chrome/Chromium/Firefox/Brave/... in terms of privacy and security features? I have my own uneducated opinion but I would like to know what the developers think.

Note: See TracTickets for help on using tickets.