Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22543 closed defect (fixed)

Tor Browser 7.0 shows window resize warning on every new window for a few seconds

Reported by: teor Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ff52-esr, tbb-7.0-issues, tbb-regression, TorBrowserTeam201708
Cc: arthuredelstein Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I open a new Tor Browser window using Tor Browser 7.0 on macOS 10.12, I see a warning about resizing the window appear for a few seconds. Then it disappears.

This only happens when I open a new window with the default content (about:tor).

When I open a new empty tab, new tab with content, or new window with content, I don't see the warning.

Child Tickets

Change History (6)

comment:1 Changed 2 years ago by cypherpunks

Keywords: ff52-esr tbb-e10s tbb-7.0-issues tbb-regression added

comment:2 Changed 2 years ago by mcs

Cc: arthuredelstein added
Keywords: tbb-e10s removed

This is easy to reproduce, at least on OSX. It occurs even when e10s is disabled.

After a window state change (sizemodechange event), the Torbutton code checks for window.windowState === 1 (which is STATE_MAXIMIZED) and then adds the resize warning notification. In TB 7.0 that state occurs each time a new window is opened (at least in response to Cmd+N on OSX). But I don't know why. It seems to have something to do with the anti-fingerprinting window sizing code, because this problem does not occur if I set privacy.resistFingerprinting = false.

I haven't tested this yet on Linux or Windows.

A side note: it seems like we should add the warning for windowState === STATE_FULLSCREEN too (but that is a different bug or a design decision that I am not familiar with).

comment:3 Changed 2 years ago by teor

The warning is shown permanently when I drag a tab out into a new window. I am using 7.0.1 in high security mode.

comment:4 Changed 2 years ago by arthuredelstein

See #22989 for a fix to all of the above-mentioned issues.

Version 0, edited 2 years ago by arthuredelstein (next)

comment:5 Changed 2 years ago by gk

Resolution: fixed
Status: newclosed

Fixed on Torbutton master and maint-1.9.7 (commit 97380447e4ab66a44abed4ec0aeb5eeabf86404e and 6aa6d6ef1355179d7198f0eb09405ac0968ba4e7) by the patch for #22989.

comment:6 Changed 2 years ago by gk

Keywords: TorBrowserTeam201708 added
Note: See TracTickets for help on using tickets.