Opened 2 years ago

Closed 2 years ago

#22546 closed defect (wontfix)

SocksListenAddress error Tor browser 7.0

Reported by: torlongtimeuser Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The code working well for order Tor Browser version,
SocksListenAddress 0.0.0.0:9150
when edit 'torrc' file, that error with Tor Browser 7.0 (I tested on windows, ubuntu linux, debian linux; all not working.).
I think this may be a bug.

how ever thanks for torproject and torteams.

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by brade

Status: newneeds_information

I don't believe this is a bug. It is caused by a change in how SocksPort configuration is handled in Tor Browser 7.0. I am sorry we did not publicize this very well.

When I add SocksListenAddress 0.0.0.0:9150 to my torrc I see this error alert:

"Tor exited during startup. This might be due to an error in your torrc file, a bug in Tor or another program on your system, or faulty hardware. Until you fix the underlying problem and restart Tor, Tor Browser will not start."

On the console I see the following messages from tor:

[warn] The SocksListenAddress option is deprecated, and will most likely be removed in a future version of Tor. Use SocksPort instead. (If you think this is a mistake, please let us know!)
[warn] SocksListenAddress can only be used with a single SocksPort with value "auto" or 1-65535 and no options set.
[warn] Failed to parse/validate config: Invalid SocksPort/SocksListenAddress configuration
[err] Reading config failed--see warnings above.

In Tor Browser 7.0, Tor Launcher passes an arg to tor (via argv) that looks like this:

+SocksPort 127.0.0.1:9150

This means that the SocksListenAddress line that you added conflicts with the configuration that Tor Launcher is passing to tor.

Do you think you need to use SocksListenAddress? Note that this config directive has been deprecated. You can add more SocksPort lines to your torrc to have tor listen on more interfaces and/or ports.

comment:2 Changed 2 years ago by torlongtimeuser

Thank you so much! I follow the code '+SocksPort' it works now, and really help me a lot.

Sorry, I didn't know this change before.

Also, there have another way. That need install a software 'Privoxy' to configure socks port.
Not really need 'SocksListenAddress', but edit torrc better than install more software.

Why I need config to other socks port?

eg: What if some website need you browser add on 'Adobe Flash Player'?


I wouldn't like add on FlashPlayer on tor browser.
Because install AdobeFlashPlayer need administrator type account.
That's mean the FlashPlayer could connect internet not use browser custom proxy.


So the problem is some plugins(like:FlashPlayer) connection internet with out tor.



Here have an idea to fix this problem.


-Creat 2 guests virtual machine on 'VirtualBox'.


Guest 1: Tor.
Guest 2: Firefox add on FlashPlayer.


-After setup network config use 'Internal Network'.
-Let Guest2(Firefox) over Guest1(Tor).


The FlashPlayer connect internet only way is over custom proxy (Tor).
Because Tor and Firefox in defferent system, config with a local aera network.


This is simply how this idea works.



I always have more than 2 guests to build multi-layer network.


2 guests virtual machine.

Guest 1: Service and Bridge-Network.
Guest 2: Tor Browser.


Tor Browser -over- Service(eg:SSH) -over- Internet(ISP)


This is like most tor user.


3 guests virtual machine.

Guest 1: Service and Bridge-Network.
Guest 2: Tor.
Guest 3: Browser. (I actually use TorBrowser removed 'tor-launcher.xpi')


Browser -over- Tor -over- Service(eg:SSH) -over- Internet(ISP)


The Web server get IP address is Tor exit node IP, even add on FlashPlayer.


even if TorBrowser send information to NSA by 'EgotisticalGiraffe', isn't my real IP.



What if some web service blocked Tor IP?

eg: When you edit Wikipedia anonymously or you search Google.


Because web server get you IP is Tor exit node IP.
When you search google may display "IPv4 Error" or something like that.
You can add a VPN or SSH server over Tor (most VPN not work to use a proxy, I was use 'SoftetherVPN' on a windows guest).


Browser -over- Service(eg:SSL-VPN) -over- Tor -over- Service(eg:SSH) -over- Internet(ISP)


In this model, the web service get final ip address is VPN IP.


So you can normally visit most website, but not onion server.



My ISP block down lots of web servers, more bad news: many servers on attack, control or blocked by government.

That's why how tor important for me.
Again, Thanks so much tor team!

comment:3 Changed 2 years ago by gk

Resolution: wontfix
Status: needs_informationclosed

Thanks. Closing this ticket as wontfix then. FWIW: Using SocksListenAddress starting with the upcoming 7.5a1 alpha release is broken from the tor side. This option will be not available anymore from the tor version on we ship in that alpha.

Note: See TracTickets for help on using tickets.