Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22558 closed defect (fixed)

OSX 10.7.5 Auto updated 6.5.1 to incompatible 7

Reported by: dehv Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201706, tbb-7.0-issues
Cc: boklm, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Shouldn't the updater detect that doing so would break the install, forcing the user to uninstall, track down old version and re-install?

Child Tickets

Change History (11)

comment:1 Changed 2 years ago by gk

Cc: boklm added
Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

boklm: Is there something we can do server-side to fix that? IIRC the plan was to update users to 6.5.2 and don't offer further upgrades (which sounds like a good plan to me).

comment:2 Changed 2 years ago by mcs

I did some debugging, and it seems like the problem is that the minSupportedOSVersion in the XML update manifest needs to use the Darwin version number instead of the macOS one. For 10.9, we should use 13.0.0. See: https://en.wikipedia.org/wiki/Darwin_(operating_system)#Release_history

comment:3 in reply to:  2 Changed 2 years ago by gk

Replying to mcs:

I did some debugging, and it seems like the problem is that the minSupportedOSVersion in the XML update manifest needs to use the Darwin version number instead of the macOS one. For 10.9, we should use 13.0.0. See: https://en.wikipedia.org/wiki/Darwin_(operating_system)#Release_history

Really? That's surprising. We had 10.8 for osx32 for years now and did not get a single bug report IIRC.

comment:4 Changed 2 years ago by gk

I just took my old OS X 10.6 out and I still had a 7.0a2 on it. While it showed me a 7.0a4 is available when trying to update I just got a "You can not perform further updates on this system"-message and a windows popped up that my system is unsupported.

Last edited 2 years ago by gk (previous) (diff)

comment:5 Changed 2 years ago by gk

The same happened with 6.5.2 on that machine fwiw.

comment:6 in reply to:  4 Changed 2 years ago by mcs

Replying to gk:

I just took my old OS X 10.6 out and I still had a 7.0a2 on it. While it showed me a 7.0a4 is available when trying to update I just got a "You can not perform further updates on this system"-message and a windows popped up that my system is unsupported.

That is because our update manifest has minSupportedOSVersion="10.9" and the Darwin version for 10.6.8 happens to be 10.8. I don't have a macOS 10.7 or 10.8 system to test with, but on a macOS 10.12.5 system osVersion is 16.6.0 after the following statement is executed:

let osVersion = Services.sysinfo.getProperty("version");

Last edited 2 years ago by mcs (previous) (diff)

comment:7 Changed 2 years ago by gk

Resolution: fixed
Status: newclosed

Ugh, yes, that makes sense. :( I have pushed fixups onto master and maint-7.0 (commit d7a6bc035327a2d92e8b4194e4c89363dede443b and 0f9bbf102c8fc9f137ec00a106e89d439d6e022b (the latter with a slightly better commit message)).

boklm, mcs: please reopen this ticket if they don't make sense. I pushed them directly to get the rebundling going.

comment:8 Changed 2 years ago by gk

Cc: mcs added
Keywords: TorBrowserTeam201706 added

comment:9 Changed 2 years ago by gk

Keywords: tbb-7.0-issues added

comment:10 Changed 2 years ago by boklm

I applied the fix manually to the 7.0 update manifests on aus1.tpo.

comment:11 Changed 2 years ago by gk

FWIW: I pushed two follow-up commits to make this whole business less error-prone/fix an error in the previous commit (on master commit 36808fe250f4c1de115fc200e1eb9294cbcdc2c0 and on maint-7.0 commit 23de6c6eaec91d4acfad764072dde2b6e58b0c6e).

Note: See TracTickets for help on using tickets.