Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22561 closed defect (duplicate)

New York Times site not only crashes Tor browser but powers down Ubuntu laptop

Reported by: TorontoBoy Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have been using Tor for about 6 months to read the New York Times, and it has worked very well so far. I have noticed recently that the NYT has done something to their web site that really slows down the Tor Browser. The index page loads, then freezes, but eventually returns. I can then browse their pages properly.

Today I tried to go to www.nytimes.com/pages/world/asia/index.html. The index page loads, but then freezes. Tor browser goes dark. The next thing that happens is that my Ubuntu 17.04 system powers itself down, then turns off. It did this twice, so I can repeat the behaviour.

This is very odd, and a bit scary that the Tor browser has this capability. I am using Tor Browser 6.5.2

I am running a Lenovo W510 laptop with Ubuntu 16.04 LTS. The NYT page loads quickly and well in Opera using VPN.

Child Tickets

Attachments (5)

tor-nyt-issue-2017-06-10 08-39-51.png (54.5 KB) - added by TorontoBoy 2 years ago.
sysmon wile using tor browser loading nyt page
tor-nyt-issue- 2017-06-10 08-44-20.png (59.4 KB) - added by TorontoBoy 2 years ago.
sysmon using tor browser 5 mins after loading nyt page
tor7-nyt-issue-2017-06-10 11-59-50.png (58.5 KB) - added by TorontoBoy 2 years ago.
sysmon using tor 7 browser just after loading nyt page
tor7-nyt-issue-2017-06-10 12-02-15.png (58.1 KB) - added by TorontoBoy 2 years ago.
sysmon using tor 7 browser first hump transition to second hump, after loading nyt page
tor7-nyt-issue-2017-06-10 12-02-39.png (59.8 KB) - added by TorontoBoy 2 years ago.
sysmon using tor 7 browser second hump finished, nyt page can now be used

Download all attachments as: .zip

Change History (13)

comment:1 Changed 2 years ago by arma

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

My theory is that you are hitting #22362, which spikes your cpu, and then your cpu overheats and the laptop turns itself off because of internal temperature.

comment:2 Changed 2 years ago by gk

Resolution: duplicate
Status: newclosed

You could test our release candidate that should fix this problem: https://people.torproject.org/~boklm/builds/7.0.1-build1/. Indeed, as arma said, this is very likely a duplicate of #22362. If not, and the 7.0.1 release candidate is not solving this issue for you, please reopen the ticket.

Changed 2 years ago by TorontoBoy

sysmon wile using tor browser loading nyt page

Changed 2 years ago by TorontoBoy

sysmon using tor browser 5 mins after loading nyt page

comment:3 Changed 2 years ago by TorontoBoy

Laptop is an i7, has 8 cpus. Upon page load one cpu goes to 100%. It is morning, cooler and I just booted up, so laptop is cool. Cpu stayed at 100% for about 5 minutes, then the issue seemed to resolve, the cpu went down to normal, after which I could browse normally.

I'll try to test the tor rc version you suggested.

comment:4 Changed 2 years ago by TorontoBoy

Installed the pushed Tor 7.0 update, which updated with no issues. Went back to the NYT web page. Index page loaded, then one cpu went to 100% for a couple of minutes, then subsided. A couple of seconds later a different cpu went to 100% for a couple of minutes, then subsided. After this I was able to surf the NTY as normal.

Whereas with Tor 6.5.2 I had one long process where a cpu hit 100%, this time I had 2 shorter processes where 2 separate cpus hit 100%.

Screen caps attached

Changed 2 years ago by TorontoBoy

sysmon using tor 7 browser just after loading nyt page

Changed 2 years ago by TorontoBoy

sysmon using tor 7 browser first hump transition to second hump, after loading nyt page

Changed 2 years ago by TorontoBoy

sysmon using tor 7 browser second hump finished, nyt page can now be used

comment:5 in reply to:  4 Changed 2 years ago by cypherpunks

Replying to TorontoBoy:

Installed the pushed Tor 7.0 update, which updated with no issues. Went back to the NYT web page. Index page loaded, then one cpu went to 100% for a couple of minutes, then subsided. A couple of seconds later a different cpu went to 100% for a couple of minutes, then subsided. After this I was able to surf the NTY as normal.

Whereas with Tor 6.5.2 I had one long process where a cpu hit 100%, this time I had 2 shorter processes where 2 separate cpus hit 100%.

Screen caps attached

e10s \o/ :-)
BTW, you were asked to test version in comment:2, not 7.0.

comment:6 Changed 2 years ago by TorontoBoy

The Tor 7.0 upgrade came to me just by chance, so I upgraded. I'm still trying to figure out how to do the 7.0.1 upgrade.

What is "e10s"? arms outstretched smiley face, I know.

Last edited 2 years ago by TorontoBoy (previous) (diff)

comment:7 Changed 2 years ago by TorontoBoy

Last edited 2 years ago by TorontoBoy (previous) (diff)

comment:8 Changed 2 years ago by TorontoBoy

Tor 7.0.1 arrived in a push yesterday. This fixed my NYT issue completely. No cpus going at 100% at any time.

Thank you very much. You people know your stuff.

Note: See TracTickets for help on using tickets.