Opened 2 years ago

Closed 2 years ago

#22573 closed defect (duplicate)

GPG-key fetch instructions are out of date on verifying signatures website

Reported by: gk Owned by: hiro
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #10073 Points:
Reviewer: Sponsor:

Description

Following our guide on how to import the Tor Browser signing key:

gpg --keyserver pool.sks-keyservers.net --recv-keys 0x4E2C6E8793298290

leads to an error:

gpg: requesting key 93298290 from hkp server pool.sks-keyservers.net
?: pool.sks-keyservers.net: Host not found
gpgkeys: HTTP fetch error 7: couldn't connect: Connection timed out

Alternatively one is getting a "Connection refused" error.

Reported on our blog: https://blog.torproject.org/comment/269018#comment-269018

Child Tickets

Change History (4)

comment:1 Changed 2 years ago by pastly

I believe this is an intermittent issue that may be caused by unreliable key servers in the pool. I was able to fetch the TB signing key from the pool with this command, and with this command wrapped with torsocks. I suspect the user was either unlucky or wasn't connect to the Internet.

Why do we have users specify pool.sks-keyservers.net?

comment:2 Changed 2 years ago by gk

Dunno, but fwiw I had the same issue (I tried before filing this bug).

comment:3 Changed 2 years ago by hiro

Owner: changed from linda to hiro
Parent ID: #10073
Status: newaccepted

comment:4 Changed 2 years ago by atagar

Resolution: duplicate
Status: acceptedclosed
Note: See TracTickets for help on using tickets.