Opened 7 months ago

Last modified 6 days ago

#22582 reopened defect

www.nexusmods.com not working properly in TOR

Reported by: WalrusInAnus Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability-website, cloudflare
Cc: Actual Points:
Parent ID: #18361 Points:
Reviewer: Sponsor:

Description

Take a look at http://www.nexusmods.com/skyrimspecialedition/mods/9567/
When you click on any of the horizontal tabs, the browser displays the letter "E" instead of the expected content.
I am using TOR v7.

Child Tickets

Change History (24)

comment:1 Changed 7 months ago by WalrusInAnus

Component: - Select a componentWebpages/Website
Owner: set to linda

comment:2 Changed 7 months ago by WalrusInAnus

Component: Webpages/Website- Select a component

comment:3 Changed 7 months ago by cypherpunks

Component: - Select a componentApplications/Tor Browser
Owner: changed from linda to tbb-team
Priority: Very HighMedium
Severity: CriticalNormal
Status: newassigned

This a duplicate of #22364.

In short, the problem is on the server side. It's probably better to contact the nexusmods administrators and ask them to change their Cloudflare configuration with regards to Tor traffic.

comment:4 in reply to:  3 ; Changed 7 months ago by gk

Replying to cypherpunks:

This a duplicate of #22364.

In short, the problem is on the server side. It's probably better to contact the nexusmods administrators and ask them to change their Cloudflare configuration with regards to Tor traffic.

You mean the problem is Cloudflare, right? (And it's not really a duplicate. While I could reproduce the issue in #22364 and verified that it got fixed in the alphas, the site is basically busted for me right now)

comment:5 Changed 7 months ago by gk

Keywords: tbb-usabiliity-website cloudflare added

comment:6 in reply to:  4 Changed 7 months ago by cypherpunks

Replying to gk:

Replying to cypherpunks:

This a duplicate of #22364.

In short, the problem is on the server side. It's probably better to contact the nexusmods administrators and ask them to change their Cloudflare configuration with regards to Tor traffic.

You mean the problem is Cloudflare, right? (And it's not really a duplicate. While I could reproduce the issue in #22364 and verified that it got fixed in the alphas, the site is basically busted for me right now)

Yes, the problem is still Cloudflare. When i first visited the link the whole site was missing styling (is this what you meant with busted?) which was also caused by Cloudflare by shielding the style sheets behind CAPTCHAs.

I verified this by looking at the Network tab and directly visiting the style sheets. After solving the CAPTCHAs and reloading the original link, the website looked okay.

There is something weird going on with the tabs on the website though. Using the Network tab in the Developer Tools and clicking on the tabs on the website, it displays the resource it's trying to load. Looking at the response in the sidepane shows the page source which looks like the typical Cloudflare CAPTCHA page. However, going directly to the resource works without a CAPTCHA being presented. I believe this is some quirk in how Cloudflare determines what requests are suspect.

comment:7 Changed 7 months ago by WalrusInAnus

Damn site stopped working again. Previously with Tor v7, I think when manually opening a direct link to any image hosted there triggered a captcha, but not anymore.

comment:8 Changed 7 months ago by WalrusInAnus

Interesting find: I changed Tor's useragent from Firefox 52 to 54 and the captchas started showing up again.

comment:9 in reply to:  8 Changed 7 months ago by gk

Replying to WalrusInAnus:

Interesting find: I changed Tor's useragent from Firefox 52 to 54 and the captchas started showing up again.

I poked Cloudflare folks again. I hope they'll fix that on their end. (Changing the User Agent to the one for Firefox 54 is not a recommended solution as it makes you stick out of the Tor Browser crowd).

comment:10 Changed 6 months ago by cypherpunks

Keywords: tbb-usability-website added; tbb-usabiliity-website removed

comment:11 Changed 2 months ago by cypherpunks

Resolution: not a bug
Status: assignedclosed

This kind of discussion is OFF-TOR. They are blocking Tor. See #ListOfServiceBlockingTor.

--

One more step
Please complete the security check to access www.nexusmods.com
Why do I have to complete a CAPTCHA?

Completing the CAPTCHA proves you are a human and gives you temporary access to the web property.
What can I do to prevent this in the future?

If you are on a personal connection, like at home, you can run an anti-virus scan on your device to make sure it is not infected with malware.

If you are at an office or shared network, you can ask the network administrator to run a scan across the network looking for misconfigured or infected devices.

Another way to prevent getting this page in the future is to use Privacy Pass. Check out the browser extension in the Firefox Add-ons Store.

comment:12 Changed 2 months ago by gk

Resolution: not a bug
Status: closedreopened

Please don't close random tickets, thanks.

comment:13 Changed 5 weeks ago by cypherpunks

Parent ID: #18361

comment:14 Changed 5 weeks ago by cypherpunks

Resolution: worksforme
Status: reopenedclosed

comment:15 Changed 5 weeks ago by gk

Resolution: worksforme
Status: closedreopened

It's still an issue, please stop close random bugs, thanks.

comment:16 Changed 5 weeks ago by cypherpunks

Priority: MediumVery Low
Reviewer: gk
Severity: NormalBlocker
Sponsor: Sponsor4
Status: reopenedneeds_information
Summary: www.nexusmods.com not working properly in TORCrazy modder advertising his mod on this ticket
Type: defecttask

comment:17 Changed 5 weeks ago by gk

Owner: tbb-team deleted
Priority: Very LowMedium
Reviewer: gk
Severity: BlockerNormal
Sponsor: Sponsor4
Status: needs_informationassigned
Summary: Crazy modder advertising his mod on this ticketwww.nexusmods.com not working properly in TOR
Type: taskdefect

comment:18 Changed 5 weeks ago by gk

Owner: set to tbb-team

comment:19 Changed 4 weeks ago by cloudflarezoey

Parent ID: #18361

comment:20 Changed 3 weeks ago by cypherpunks

Parent ID: #18361

Reverting change caused by damn Cloudflare employee.

comment:21 Changed 12 days ago by cypherpunks

Resolution: worksforme
Status: assignedclosed

They massively changed the website.

comment:22 Changed 12 days ago by cypherpunks

Parent ID: #18361

comment:23 in reply to:  21 Changed 12 days ago by gk

Resolution: worksforme
Status: closedreopened

Replying to cypherpunks:

They massively changed the website.

Again, please don't close random bugs. This is still an issue.

comment:24 Changed 6 days ago by cypherpunks

Parent ID: #18361
Note: See TracTickets for help on using tickets.