Opened 2 years ago

Last modified 4 months ago

#22589 assigned defect

Tor circuit is too slow!

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: performance needs-analysis tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Right now I'm trying to download another version of browser from https://dist.torproject.org/torbrowser, but it shows 4 KB/sec (3 hours to complete)!
Why do such circuits present?

Child Tickets

Change History (14)

comment:1 Changed 2 years ago by cypherpunks

400 KB/sec after switching circuit.

comment:2 Changed 2 years ago by gk

Resolution: invalid
Status: newclosed

Well, the reason for being that slow could be many, but Tor Browser is not messing with the path selection (and won't do that). So there is nothing we could do about this issue from Tor Browser land.

comment:3 Changed 2 years ago by cypherpunks

Component: Applications/Tor BrowserCore Tor/Tor
Resolution: invalid
Status: closedreopened
Version: Tor: 0.3.0.7

Then it is entirely Core Tor issue.

comment:4 Changed 2 years ago by cypherpunks

Resolution: not a bug
Status: reopenedclosed

When you say "Tor is too slow!" you are talking about the Tor network. You might help make it faster by adding more fast tor relays.

comment:5 Changed 2 years ago by cypherpunks

Resolution: not a bug
Status: closedreopened

This ticket is about Tor is dividing relay's bandwidth by too many (infinite?) clients, so that each of them has 4 KB/sec, while other relays offer more than 400 KB/sec.
Let's wait for Tor Team to answer.

comment:6 Changed 2 years ago by cypherpunks

There is some information on this topic in the FAQ. See https://www.torproject.org/docs/faq#WhySlow.

comment:7 Changed 2 years ago by cypherpunks

Component: Core Tor/Tor- Select a component
Resolution: invalid
Status: reopenedclosed
Version: Tor: 0.3.0.7

This is not a problem due to Tor Core.

comment:8 Changed 2 years ago by cypherpunks

Component: - Select a componentCore Tor/Tor
Resolution: invalid
Status: closedreopened

WTF are you doing?
If you can't read comments, don't modify tickets!

comment:9 Changed 2 years ago by cypherpunks

Keywords: performance added
Owner: changed from tbb-team to nickm
Status: reopenedassigned

"The average website today is nearly 2.5 megabytes"
Nick, how do you think 4 KB/sec is enough for Tor Browser?

comment:10 Changed 2 years ago by cypherpunks

The metrics website also has some information on the performance of the Tor network (see https://metrics.torproject.org/torperf.html).

comment:11 Changed 2 years ago by teor

Milestone: Tor: unspecified
Status: assignedneeds_information

This might be an instance of #22663, but it's hard to tell without further information.
It would help to know which relay in the circuit is slow, but don't post your guard, that wrecks your anonymity.

comment:12 Changed 2 years ago by cypherpunks

Status: needs_informationnew
Summary: Tor is too slow!Tor circuit is too slow!

This might be anything, except an instance of #22663. It would be good to know which relay in the circuit is slow: 2nd or exit. But we need to see the throughput per circuit of each relay for this.

comment:13 Changed 2 years ago by nickm

Keywords: needs-analysis tor-client added

comment:14 Changed 4 months ago by nickm

Owner: nickm deleted
Status: newassigned

These tickets are not things I'm currently working on. They may be important, but they don't need to be done by me specifically. Un-assigning.

Note: See TracTickets for help on using tickets.