Opened 2 years ago

Last modified 2 years ago

#22591 assigned defect

Clicking on a comment does not directly jump to it (although the blog seems to try)

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability-website
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Looking at Content -> Comments and selecting one (e.g. in order to reply to it) does some jumping but one never lands at the comment one clicked. Rather, one needs to focus the URL bar and hit return to finish the jump to the comment in question.

Child Tickets

Change History (32)

comment:1 Changed 2 years ago by cypherpunks

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:2 Changed 2 years ago by hiro

This is now implemented.

comment:3 Changed 2 years ago by hiro

Resolution: fixed
Status: newclosed

comment:4 Changed 2 years ago by gk

Resolution: fixed
Status: closedreopened

Hm, that still does not work for me in all cases. For instance I logged in and looked at the comment queue, scrolled down until I found https://blog.torproject.org/comment/270924#comment-270924 and clicked on it. The blog seems to try jumping to it but fails.

comment:5 Changed 2 years ago by gk

It's enough for me to open that link in a new tab if I am logged in into the blog. I am using Tor Browser on a low slider level.

comment:6 Changed 2 years ago by cypherpunks

The same issue, but with Trac https://trac.edgewall.org/ticket/12427

comment:7 Changed 2 years ago by hiro

Is this a browser issue or some system issue? I have tested this on firefox nightly and 55 on linux. In both cases it works ok for me. Same on Tor browser.

comment:8 in reply to:  7 ; Changed 2 years ago by gk

Replying to hiro:

Is this a browser issue or some system issue? I have tested this on firefox nightly and 55 on linux. In both cases it works ok for me. Same on Tor browser.

This happens with a Tor Browser alpha on a XFCE Debian testing system with a 1000x600 browser window.

comment:9 in reply to:  8 ; Changed 2 years ago by gk

Replying to gk:

Replying to hiro:

Is this a browser issue or some system issue? I have tested this on firefox nightly and 55 on linux. In both cases it works ok for me. Same on Tor browser.

This happens with a Tor Browser alpha on a XFCE Debian testing system with a 1000x600 browser window.

Let me do a bit more testing, I might be able to track this better down...

comment:10 in reply to:  9 Changed 2 years ago by gk

Replying to gk:

Replying to gk:

Replying to hiro:

Is this a browser issue or some system issue? I have tested this on firefox nightly and 55 on linux. In both cases it works ok for me. Same on Tor browser.

This happens with a Tor Browser alpha on a XFCE Debian testing system with a 1000x600 browser window.

Let me do a bit more testing, I might be able to track this better down...

Yeah, here are the steps that reproduce this issue for me (I tried several times):

1) Take a new 7.5a4 en-US Linux 64 bit bundle
2) Go to this bug
3) Load the URL in comment:4 in a new tab
4) Switch to the tab and you'll see that the comment is almost jumped to. In my case I and at the previous one or so
5) Focusing the URL bar and hitting Enter jumps finally to the intended comment.

Version 0, edited 2 years ago by gk (next)

comment:11 Changed 2 years ago by hiro

Ok, but this might not be a trac or blog bug as rather a browser bug? I'd like to make the following test, I create a page with some text and some anchors links. If the behaviour is the same this can be considered a browser bug rather than an issue w/ the html of the blog or trac.

Will follow up w/ the page.

comment:12 in reply to:  11 Changed 2 years ago by gk

Resolution: worksforme
Status: reopenedclosed

Replying to hiro:

Ok, but this might not be a trac or blog bug as rather a browser bug? I'd like to make the following test, I create a page with some text and some anchors links. If the behaviour is the same this can be considered a browser bug rather than an issue w/ the html of the blog or trac.

Will follow up w/ the page.

I did some more testing. This seems to me intermittent. So, as you indicated, it might actually be not a blog bug. Maybe it's just my machine. Until I've got better steps to reproduce let's close this as WORKSFORME. Sorry for the additional work.

comment:13 Changed 2 years ago by cypherpunks

Resolution: worksforme
Status: closedreopened

Reproducible on Windows 10. Security Settings on Low and a lot of opened tabs seem to be viable.

comment:14 Changed 2 years ago by hiro

Hi,

Can you please try this page from the w3 site?

https://www.w3.org/TR/html4/struct/links.html#h-12.1.5

It is just plain html and doesn't load any JS. Can you observe the same behaviour? If this is not related to the blog but rather the browser/system maybe we should give a heads up to the firefox people.

Last edited 2 years ago by hiro (previous) (diff)

comment:15 in reply to:  14 Changed 2 years ago by cypherpunks

Replying to hiro:
No issues.

comment:16 Changed 2 years ago by gk

Another data point: I can't reproduce the problem with JavaScript disabled. I tried pretty hard. But with JavaScript enabled it is easy for me to hit it.

comment:17 Changed 2 years ago by hiro

Hi,

When you tried w/ JS enabled were you logged into the blog?

The admin interface loads more javascript that the blog itself. The blog only loads: underscorejs.org

comment:18 Changed 2 years ago by gk

No, I was not logged in. Here is what I did: I reloaded the blog comment in comment:4 ten times over a different Tor circuit with JavaScript enabled and ten times without (I flipped javascript.enabled) and restarted between both tests.

Without JavaScript enabled I did not see a single instance of this issue. With JavaScript enabled I saw it in 8 cases.

comment:19 Changed 2 years ago by hiro

I have removed JS in the dev-blog template. Can you reproduce the issue on this link?

https://dev-tor-blog-8.pantheonsite.io/comment/268756#comment-268756

comment:20 Changed 2 years ago by hiro

To access the dev blog use the following credentials:

user: tor

pass: blog

comment:21 in reply to:  19 Changed 2 years ago by gk

Replying to hiro:

I have removed JS in the dev-blog template. Can you reproduce the issue on this link?

https://dev-tor-blog-8.pantheonsite.io/comment/268756#comment-268756

No. But I can't reproduce it for that particular comment on the live blog either. So, not a good test case. :) (But I can with the comment mentioned in comment:4 on the live blog)

comment:22 Changed 2 years ago by hiro

JS is disabled everywhere on the dev blog at the moment. So if you have the time to surf around a bit that would be nice. There isn't the same comment on the prod and dev blogs, but certainly we use the same template.

comment:23 in reply to:  22 Changed 2 years ago by cypherpunks

Replying to hiro:

JS is disabled everywhere on the dev blog at the moment. So if you have the time to surf around a bit that would be nice. There isn't the same comment on the prod and dev blogs, but certainly we use the same template.

STR in comment:10 still work and can be used to find links with this issue, e.g. https://dev-tor-blog-8.pantheonsite.io/comment/268454#comment-268454 or https://dev-tor-blog-8.pantheonsite.io/comment/268314#comment-268314 (not always reproducible)

Last edited 2 years ago by cypherpunks (previous) (diff)

comment:24 Changed 2 years ago by gk

Okay, after quite some testing I found a comment on the dev blog that even shows the issue (or a similar one) with a clean, new vanilla Firefox on my Linux system: https://dev-tor-blog-8.pantheonsite.io/comment/258307#comment-258307. However, I have to be logged in to trigger the problem in this case. For Firefox I need to press "Ctrl + Shift + R" to reload the page and then after that's done hitting Enter will jump down to the comment.

Last edited 2 years ago by gk (previous) (diff)

comment:25 Changed 2 years ago by gk

Oh, that's the Firefox ESR 52 Debian ships.

comment:26 Changed 2 years ago by gk

Doing the daily comment approval thing makes me believe that this issue is even more easily reproducible with being logged in (but it might be slightly different one, see comment:24).

comment:27 Changed 2 years ago by cypherpunks

This is, probably, a Firefox issue as it is observable on trac.tpo and other sites (e.g. https://trac.torproject.org/projects/tor/ticket/18361#comment:235).

comment:28 Changed 2 years ago by hiro

Gk I have disabled JS in the dev blog for the normal template. However if you are logged in, the drupal toolbar loads some javascript libraries, and so does the admin template.

This means it might be an issue w/ how firefox loads some function of underscorejs.org (and other libraries loaded by trac.tpo and other websites) or w/ firefox itself.

Also could it be something that is solved in newer versions of firefox?

Also please let me know what we should do regarding this ticket. I do not think we should track this as a blog issue, but I'd be happy to debug it more if we really think it could be useful.

comment:29 in reply to:  28 Changed 2 years ago by gk

Component: Webpages/BlogApplications/Tor Browser
Keywords: tbb-usability-website added
Parent ID: #22013

Replying to hiro:

Gk I have disabled JS in the dev blog for the normal template. However if you are logged in, the drupal toolbar loads some javascript libraries, and so does the admin template.

This means it might be an issue w/ how firefox loads some function of underscorejs.org (and other libraries loaded by trac.tpo and other websites) or w/ firefox itself.

Also could it be something that is solved in newer versions of firefox?

That's still an issue in the latest Firefox nightly.

Also please let me know what we should do regarding this ticket. I do not think we should track this as a blog issue, but I'd be happy to debug it more if we really think it could be useful.

If you feel that's not blog business but Tor Browser/Firefox one I am fine setting the component accordingly. In fact let me do that right away.

comment:30 Changed 2 years ago by gk

Owner: changed from hiro to tbb-team
Status: reopenedassigned

comment:31 Changed 2 years ago by hiro

Hi gk, I am not sure it is a blog issue, but I am not sure it's a firefox issue either. Might be something to do with some function in that library.

Maybe, before investigating this as a browser bug, I can try replace that w/ standard jquery, or remove it completely (better option) as JS is only used to submit comments. What do you think?

comment:32 in reply to:  31 Changed 2 years ago by gk

Replying to hiro:

Hi gk, I am not sure it is a blog issue, but I am not sure it's a firefox issue either. Might be something to do with some function in that library.

Maybe, before investigating this as a browser bug, I can try replace that w/ standard jquery, or remove it completely (better option) as JS is only used to submit comments. What do you think?

Well, I have the same problem with Trac (see comment:27). Once I disable JS the jumping works but with it on there are issues as well. That said, I am happy to have less JS on the blog (and/or on Trac), so go for that if you can. :)

Note: See TracTickets for help on using tickets.