Opened 2 years ago

Closed 2 years ago

#22604 closed task (duplicate)

GetTor better channels

Reported by: dracofrog Owned by: ilv
Priority: Medium Milestone:
Component: Applications/GetTor Version:
Severity: Normal Keywords: GetTor, Torrent
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

GetTor is a service that provides alternative methods to download the Tor Browser, especially for people living in places with high levels of censorship, where access to Tor Project's website is restricted.

If you have suggestions for more/better channels
Torrent
Puablic magnet

Child Tickets

Change History (1)

comment:1 Changed 2 years ago by ilv

Resolution: duplicate
Status: newclosed

Duplicate of #9071

Note: See TracTickets for help on using tickets.