Opened 17 months ago

Closed 3 weeks ago

#22649 closed defect (duplicate)

Save Link As... in the context menu results in using the catch-all circuit

Reported by: gk Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-7.0-issues, tbb-regression, tbb-linkability, tbb-usability
Cc: mcs, brade, arthuredelstein, dwatson@…, dmr Actual Points:
Parent ID: #22343 Points:
Reviewer: Sponsor:

Description

This is a spin-off of #22343 where it got noticed that Save Link As... goes over the catch-all circuit as well. As the external helper app dialog is involved it might be related to the trouble we had with getting that one working...

Child Tickets

Change History (6)

comment:1 Changed 17 months ago by gk

Keywords: tbb-linkability added

comment:2 Changed 17 months ago by gk

Priority: MediumHigh
Severity: NormalMajor

comment:3 Changed 14 months ago by cypherpunks

Also trying this with https://www.eff.org/files/https-everywhere-test/https-everywhere-2017.9.12.1337-eff.xpi results in

05:33:23.922 unsafe CPOW usage forbidden 1 contentAreaUtils.js:466
	continueSave chrome://global/content/contentAreaUtils.js:466:1
	internalSave/< chrome://global/content/contentAreaUtils.js:446:7
	Handler.prototype.process resource://gre/modules/Promise-backend.js:932:23
	this.PromiseWalker.walkerLoop resource://gre/modules/Promise-backend.js:813:7
	bound  self-hosted:913:17
	bound bound  self-hosted:913:17
	this.PromiseWalker.scheduleWalkerLoop/< resource://gre/modules/Promise-backend.js:747:11

comment:4 Changed 12 months ago by davidw

Cc: dwatson@… added

I can confirm this. I originally posted to #22616 but it seems more appropriate here.

The problem for me is concurrent downloads. First download always works but trying to download another file at the same time always fails with this:

unsafe CPOW usage forbidden  				contentAreaUtils.js:466
	continueSave 		chrome://global/content/contentAreaUtils.js:466:1
	internalSave/< 		chrome://global/content/contentAreaUtils.js:446:7
	Handler.prototype.process resource://gre/modules/Promise-backend.js:932:23
	this.PromiseWalker.walkerLoop		resource://gre/modules/Promise-backend.js:813:7
	bound  							self-hosted:913:17
	bound bound  						self-hosted:913:17
	this.PromiseWalker.scheduleWalkerLoop/< resource://gre/modules/Promise-backend.js:747:11

Mac OS 10.11.6 with Tor 7.0.6 (64bit), and also 7.5a8

comment:5 Changed 3 months ago by dmr

Cc: dmr added
Keywords: tbb-usability added
Parent ID: #22343

From 22343#comment:51:

This can have usability implications when switching a circuit for saving would prevent access to the resource.
For instance:

  • Cloudflare-/captcha-gated sites
  • scenarios where the resource is only available after login
  • other scenarios that require some sort of cookie / client attestation / etc.

I believe the same thing is applicable here. Adding keyword.

Also defining a parent relation, since I believe that helps these get resolved together.
(Please lmk if that is against the tbb workflow!)

comment:6 Changed 3 weeks ago by gk

Resolution: duplicate
Status: newclosed

Moving this over to #22343 and closing ticket as duplicate.

Note: See TracTickets for help on using tickets.