Opened 5 months ago

Closed 5 months ago

#22655 closed defect (fixed)

Blog: feed has broken redirection

Reported by: cypherpunks Owned by: hiro
Priority: High Milestone:
Component: Webpages/Blog Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Steps to reproduce:

  1. open https://blog.torproject.org/blog/feed , a feed URL provided by the page https://blog.torproject.org/ in any web browser (Tested: Firefox with different modifications, Epiphany)

What happens:
Loading the page fails with too many redirections.
The server sends a "301 Moved Permanently" status to the same URL (https://blog.torproject.org/blog/feed) until the browser aborts loading the page because of too many redirects.

What should happen:
Do not redirect recursively. You might want to redirect to https://blog.torproject.org/rss.xml.

Child Tickets

Change History (2)

comment:1 Changed 5 months ago by cypherpunks

Seems to be fixed now. I'll leave this open for an admin to verify. It might have happened sporadically.

comment:2 Changed 5 months ago by hiro

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.