#22690 closed defect (not a bug)

SR: Authorities can add a reveal to their own vote, but expect a commit in all votes

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-sr
Cc: Actual Points:
Parent ID: Points: 2
Reviewer: Sponsor:

Description (last modified by teor)

This is the chutney output:

PASS: hs-min
Detail: chutney/tools/warnings.sh /Users/USERS/tor/tor-master/../chutney/tools/../net/nodes.1498090178
Warning: SR: Commit from authority 234887728412ECD247629DD98884444735F1A7AA has a reveal value during COMMIT phase. (voter: 234887728412ECD247629DD98884444735F1A7AA) Number: 1

I will attach the full chutney directory.

Child Tickets

Attachments (1)

nodes.1498090178.zip (475.4 KB) - added by teor 18 months ago.
chutney directory

Download all attachments as: .zip

Change History (6)

comment:1 Changed 18 months ago by teor

Description: modified (diff)

comment:2 Changed 18 months ago by dgoulet

Milestone: Tor: 0.3.1.x-finalTor: 0.3.2.x-final
Status: newneeds_information

This is possible with a bad clock on the authority side which makes the relay thinks that it's in the REVEAL phase but it is in fact in the COMMIT phase.

A bit weird though that you get that on chutney because all relays have the same clock! The logs here will definitely help out.

Changed 18 months ago by teor

Attachment: nodes.1498090178.zip added

chutney directory

comment:3 in reply to:  2 ; Changed 18 months ago by teor

Replying to dgoulet:

This is possible with a bad clock on the authority side which makes the relay thinks that it's in the REVEAL phase but it is in fact in the COMMIT phase.

A bit weird though that you get that on chutney because all relays have the same clock! The logs here will definitely help out.

chutney does some weird things with TestingV3AuthVotingStartOffset that might cause this issue. Occasionally one authority starts before the offset, and another starts after it, and their consensuses get out of sync.

But this is really weird: it is an authority rejecting its own vote, so it has to have the same clock, right?

comment:4 in reply to:  3 Changed 18 months ago by dgoulet

Replying to teor:

Replying to dgoulet:

This is possible with a bad clock on the authority side which makes the relay thinks that it's in the REVEAL phase but it is in fact in the COMMIT phase.

A bit weird though that you get that on chutney because all relays have the same clock! The logs here will definitely help out.

chutney does some weird things with TestingV3AuthVotingStartOffset that might cause this issue. Occasionally one authority starts before the offset, and another starts after it, and their consensuses get out of sync.

But this is really weird: it is an authority rejecting its own vote, so it has to have the same clock, right?

I don't think so. The warning simply says that it received the 234887728412ECD247629DD98884444735F1A7AA commit value with a reveal which was seen in the 234887728412ECD247629DD98884444735F1A7AA vote.

That log warning should *not* have been emitted by 234887728412ECD247629DD98884444735F1A7AA else we have another problem!

comment:5 Changed 15 months ago by dgoulet

Resolution: not a bug
Status: needs_informationclosed

No news in a while and nobody hitting this on chutney now, closing. But let's re-open if this re-appears.

The entire SR phases and duration are based on the valid_after consensus time so it can happen in theory with a bad block or out of sync consensus between authorities.

Note: See TracTickets for help on using tickets.