Opened 4 months ago

Closed 6 weeks ago

#22750 closed defect (fixed)

Incorrect syscall in some sandbox error messages

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version: Tor: 0.2.5.1-alpha
Severity: Minor Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

These are probably the result of some copy-pasting.

Child Tickets

Attachments (1)

0001-Use-the-proper-syscall-in-sandbox-error-messages.patch (2.1 KB) - added by cypherpunks 4 months ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 months ago by cypherpunks

Status: newneeds_review
Version: Tor: 0.2.5.1-alpha

The issue is present across multiple versions with the oldest being 0.2.5.1-alpha.

The commits that introduced the issues are 8a85a48b9d0ed2b298bcc26dfeb96fa7e31c05c4 for function sb_stat64 on 0.2.5.1-alpha and dd7c99961774c19c6042100e660104c687ad6e22 for functions sb_chmod and sb_chown on tor-0.2.8.2-alpha

I didn't feel like splitting such a simple patch in two and basing each part on a different maintenance branch so its based on master instead.

comment:2 Changed 4 months ago by nickm

Milestone: Tor: 0.3.2.x-final
Status: needs_reviewmerge_ready

I think it's fine to take these in master.

comment:3 Changed 4 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

Merged to master; thank you!

comment:4 Changed 4 months ago by cypherpunks

Resolution: fixed
Status: closedreopened

You've added your own changes file, but the patch already includes one so now there are two (changes/ticket22750 and changes/bug22750).

comment:5 Changed 6 weeks ago by nickm

Resolution: fixed
Status: reopenedclosed

removed one. thanks!

Note: See TracTickets for help on using tickets.