Opened 19 months ago

Last modified 4 months ago

#22770 new defect

Cookie protections dialog cannot delete cookies after upgrade

Reported by: pastly Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: cookies
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The following is originally reported by someone with an offsensive username. The person reports using XP SP3. It is unclear whether or not he still has unsupported addons or modifications to cache/history settings.



Cookie protections dialog cannot delete cookies after I upgraded TorBrowser and restarted it.

  1. Had TorBrowser 6.5.x (running)
  2. Updated to 7.0.1
  3. Killed TorBrowser process
  4. Started TorBrowser (7.0.1)
  5. Tabs got recovered (NOTE: for some reason didn't show me tab recovery dialog)
  6. Now when I use Cookie protections dialog, I click to delete cookies, but when I click OK and close dialog, all cookies are still there!!! I reopen Cookie protections dialog and they are still in. They aren't protected but behave like they were.
  7. When I open Tools->Options->Privacy->cookies, I can properly delete cookies from there.

I haven't restart browser yet so don't know if it happens after restart.

It's critical privacy bug. You think you deleted cookies so you reload page with new circuit, but in fact, you are using your old cookies and they will know it's same person. They will link your two accounts.

Also, when I click to protect or unprotect cookie in the dialog, and click OK, it gets saved. When I reopen dialog I see that it's saved what I protected. But cannot delete cookies.


Finally, I restarted TorBrowser (7.0.1). It's still broken, restart doesn't help.


The save image/page bugs were indeed fixed by updating old addons, but I noticed this cookie bug is still present, so I reopen it.
As said initially, marking cookies as protected/unprotected works correctly, but it's not possible to delete cookies (they are deleted from dialog but reappear when you open it again). Deleting cookies from Tools->Options->Privacy->Cookies works totally fine.

Child Tickets

Change History (3)

comment:1 Changed 19 months ago by cypherpunks

with a completely unmodified tbb 7, switch browser.privatebrowsing.autostart to false and then delete cookies as reported, it doesn't work
the work around the original reporter gave works but it's less convenient

comment:2 Changed 18 months ago by Runawe

Problem still exists in Tor Browser 7.0.4

comment:3 Changed 4 months ago by az

I can reproduce this with Tor Browser 8.0 on linux.

Note: See TracTickets for help on using tickets.