Opened 3 months ago

Closed 3 months ago

#22812 closed defect (not a bug)

find_dl_min_and_max_delay's DL_SCHED_DETERMINISTIC case is never used

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version: Tor: 0.2.9.5-alpha
Severity: Normal Keywords: easy technical-debt mostly-harmless
Cc: Actual Points: 0.1
Parent ID: #17750 Points: 0.5
Reviewer: Sponsor:

Description

find_dl_min_and_max_delay is never called with DL_SCHED_DETERMINISTIC schedules. So we should just remove that case entirely. And replace it with a BUG() return.

Child Tickets

Change History (2)

comment:1 Changed 3 months ago by teor

Keywords: code-simplification removed

comment:2 Changed 3 months ago by teor

Actual Points: 0.1
Parent ID: #17750
Resolution: not a bug
Status: newclosed

Turns out these are actually used, I added comments in my #17750 branch to clarify.

Note: See TracTickets for help on using tickets.