Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#2299 closed defect (duplicate)

TLS decode error while handshaking with OpenSSL 0.9.8o

Reported by: ramsdell Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.1.26
Severity: Keywords: OpenSSL TLS decode error tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I seem to be experiencing TLS decode errors similar to ones reported for Tor 0.2.1.22. I'm running in a private network on Ubuntu 10.10 server.

John

urrtor@urr1:~/tor$ uname -a
Linux urr1 2.6.35-22-generic-pae #35-Ubuntu SMP Sat Oct 16 22:16:51 UTC 2010 i686 GNU/Linux
urrtor@urr1:~/tor$ openssl version
OpenSSL 0.9.8o 01 Jun 2010
urrtor@urr1:~/tor$ tor --version
Dec 17 15:42:13.293 [notice] Tor v0.2.1.26 (r12). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux i686)
Tor version 0.2.1.26 (r12).
urrtor@urr1:~/tor$ grep TLS urr1.log
Dec 17 15:18:45.153 [debug] connection_tls_start_handshake(): starting TLS handshake on fd 9
Dec 17 15:18:45.154 [info] TLS error while handshaking with [scrubbed]: tlsv1 alert decode error (in SSL routines:SSL23_GET_SERVER_HELLO)
Dec 17 15:18:45.155 [debug] connection_tls_start_handshake(): starting TLS handshake on fd 9
Dec 17 15:18:45.155 [info] TLS error while handshaking with [scrubbed]: tlsv1 alert decode error (in SSL routines:SSL23_GET_SERVER_HELLO)
Dec 17 15:19:46.256 [debug] connection_tls_start_handshake(): starting TLS handshake on fd 9
Dec 17 15:19:46.257 [info] TLS error while handshaking with [scrubbed]: tlsv1 alert decode error (in SSL routines:SSL23_GET_SERVER_HELLO)
Dec 17 15:24:51.780 [debug] connection_tls_start_handshake(): starting TLS handshake on fd 9
Dec 17 15:24:51.781 [info] TLS error while handshaking with [scrubbed]: tlsv1 alert decode error (in SSL routines:SSL23_GET_SERVER_HELLO)
Dec 17 15:35:01.836 [debug] connection_tls_start_handshake(): starting TLS handshake on fd 9
Dec 17 15:35:01.837 [info] TLS error while handshaking with [scrubbed]: tlsv1 alert decode error (in SSL routines:SSL23_GET_SERVER_HELLO)
urrtor@urr1:~/tor$

Child Tickets

Change History (3)

comment:1 Changed 9 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #2204, fixed in Tor 0.2.1.27 .

comment:2 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:3 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.