Opened 3 years ago

Closed 3 years ago

#22998 closed defect (fixed)

Update BridgeDB's .travis.yml to run tests for Debian buster dependency versions

Reported by: isis Owned by: isis
Priority: Medium Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Normal Keywords: bridgedb-ci, ci
Cc: Actual Points:
Parent ID: Points: 1
Reviewer: Sponsor: SponsorM

Description

weasel updated polyanthum today to Debian stretch. In keeping with running BridgeDB's CI with the currently used versions of Twisted and PyOpenSSL as well as the versions slated for the next Debian release, we'll need to update some version numbers.

Child Tickets

Change History (1)

comment:1 Changed 3 years ago by isis

Points: .51
Resolution: fixed
Sponsor: SponsorM
Status: newclosed

Fixed in my fix/22998 branch. Note that tests on Debian stretch and buster are both failing, and they are permitted to fail, due to complications with newer Twisted versions from #23032, #23033, and #23034. Tests pass with Twisted==16.1.1 however.

Note: See TracTickets for help on using tickets.