Opened 9 years ago

Closed 9 years ago

#2303 closed defect (duplicate)

download breaks, traffic still flows somewhere...

Reported by: alexnv Owned by:
Priority: Very High Milestone:
Component: Polipo Version:
Severity: Keywords: download, breaks, traffic
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When download (file 300 mb)actually stops (or better breaks, 65 mb on disk, status in browser: 0 bytes/sec, unknown time remaining), the Vidalia Bandwidth Usage graph shows that the traffic still goes on, with considerable pace (40 kb/sec).
As counter shows, more than 100mb were downloaded after the browser showed that it stopped (no other pages were opened).
All that data goes "somewhere", but is not attached to the file.

So, it seems that the bug is not a minor one.


Additional Info:
When downloading without Tor (Tor not started),
using Google chrome browser, all is ok.

System parameters:
1) OS Windows XP 5.1.2600
2) Antivirus Avira (webGuard off, firewall off)
3) Windows firewall is off
4) Event ID 4226 Patcher applied
5) Mozilla adjusted:
network.http.keep-alive.timeout:600 (300ms default is OK usually, but 600 is better.)
network.http.max-persistent-connections-per-proxy:16 (Default is 4)
network.http.pipelining:true (Default- false. Some old HTTP/1.0 servers can't handle it.)
network.http.pipelining.maxrequests:8 (No default)
network.http.proxy.keep-alive:true (Default- true, but double check)
network.http.proxy.pipelining:true (Default- false) -

Child Tickets

Change History (1)

comment:1 Changed 9 years ago by rransom

Component: Tor ClientPolipo
Resolution: duplicate
Status: newclosed
Version: Tor: 0.2.1.26

Duplicate of #2222.

Note: See TracTickets for help on using tickets.