Opened 2 years ago

Closed 2 years ago

#23036 closed defect (duplicate)

'SETCONF ORPort' crashes tor without network

Reported by: atagar Owned by:
Priority: Low Milestone:
Component: Core Tor/Tor Version:
Severity: Minor Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi Nick, on my bus commute home ran into an issue with the present git tip (tor commit bb66a48).

Repro steps:

  • Start system without a network connection.
  • Start tor, torrc I used was...
% cat ~/.tor/torrc 
ControlPort 9051
ExitPolicy reject *:*
  • Set the ORPort with "SETCONF ORPort=9090".

Result:

Tor process terminates with...

Jul 25 19:21:33.000 [warn] ControlPort is open, but no authentication method has been configured.  This means that any program on your computer can reconfigure your Tor.  That's bad!  You should upgrade your Tor controller as soon as possible.
Jul 25 19:21:33.000 [notice] Opening OR listener on 0.0.0.0:9090
Jul 25 19:21:33.000 [notice] You are running a new relay. Thanks for helping the Tor network! If you wish to know what will happen in the upcoming weeks regarding its usage, have a look at https://blog.torproject.org/blog/lifecycle-of-a-new-relay
Jul 25 19:21:33.000 [notice] It looks like I need to generate and sign a new medium-term signing key, because I don't have one. To do that, I need to load (or create) the permanent master identity key. If the master identity key was not moved or encrypted with a passphrase, this will be done automatically and no further action is required. Otherwise, provide the necessary data using 'tor --keygen' to do it manually.
Jul 25 19:21:33.000 [notice] Your Tor server's identity key fingerprint is 'Unnamed 4853AB6F9215A837EA3562CF4AF00713737FDF01'
Jul 25 19:21:33.000 [warn] Unable to parse '/etc/resolv.conf', or no nameservers in '/etc/resolv.conf' (6)
Jul 25 19:21:33.000 [err] set_options(): Bug: Acting on config options left us in a broken state. Dying. (on Tor 0.3.2.0-alpha-dev bb66a48541aa5110)

Not a big whoop. Gonna disable a stem integ test tripping over this for now though.

Thanks!

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by nickm

Thanks, Damian! Could this be a duplicate of #15421?

comment:2 Changed 2 years ago by atagar

Resolution: duplicate
Status: newclosed

Certainly sounds like it - thanks Nick! I'll dedup with that and note the repro steps there.

Note: See TracTickets for help on using tickets.