#23052 closed defect (not a bug)

I get Ukrainian IPs most of the time

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

For at least a few weeks I realized there is the text "UA" next to the Youtube logo most of the times. I would really like to know why it would happen

I can't speak for other websites since the circuit viewer never showed up on my PC for years, I don't know why

I could say at least half of the times I get the Ukrainian IP(s) on Youtube, it's crazy. Like I try dozens of times to see which countries would show up and yes, still UA most of the times

Child Tickets

Change History (3)

comment:1 Changed 14 months ago by cypherpunks

I meant

*I try "New Tor Circuit for this Site" dozens of times

comment:2 Changed 14 months ago by dcf

This phenomenon is possibly Google's geolocation being confused by the many Ukrainians that started using Tor recently. The IP addresses are not actually in Ukraine. Please see:

Is the recent growth in Ukrainian users confusing google's geoip?

Motivated by a blog post comment:
https://blog.torproject.org/comment/269237#comment-269237

It looks like a growing number of connections from Tor exits are being
treated by Google as being Ukrainian.

Anecdotally, I've experienced it too -- Google news keeps wanting to
give me Ukrainian news.

For those who haven't been paying attention, we got a jump in some
hundreds of thousands of .ua users recently:
https://metrics.torproject.org/userstats-relay-country.html?start=2017-05-01&end=2017-06-18&country=ua&events=off
and it looks like they're really users:
https://bugs.torproject.org/22369

Here's my speculation:

You know how Google's proprietary geoip system is typically better
than Maxmind's, because they data mine the heck out of their traffic,
for example by deciding that the google maps address you ask about most
is probably your home address?

I wonder if a lot of ordinary people doing ordinary things via Tor,
and acting like people in the Ukraine, has tipped Google's sekrit-sauce
machine learning decision trees into labeling those IP addresses as
being in .ua.

There are some other ideas later in the thread.

comment:3 Changed 14 months ago by gk

Resolution: not a bug
Status: newclosed

Jepp. So far I am not convinced this is an actual Tor Browser bug.

Note: See TracTickets for help on using tickets.