Opened 2 years ago

Closed 2 years ago

#23058 closed defect (fixed)

Sandbox Tor Browser no longer starting (100% CPU load)

Reported by: pege Owned by: yawning
Priority: Medium Milestone:
Component: Archived/Tor Browser Sandbox Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Sandbox Tor Browser no longer working after update to Tor Browser 7.5a3. (Also happens with a fresh install.)

tor-browser-sandboxed shows that everything is ok:

...
2017/07/28 19:33:11 sandbox: bwrap pid is: 298684
2017/07/28 19:33:11 sandbox: bwrap init pid is: 298685
2017/07/28 19:33:11 launch: Complete.
2017/07/28 19:33:11 update: Previous scheduled update check: 2017-07-28 21:15:25 +0200 CEST
2017/07/28 19:33:11 update: Initial scheduled update check: 1h42m13.489734672s

But the firefox process uses 100% CPU and appears to be stuck in an endless loop:

$ strace -p 298688
read(-2, 0x7ffcbab09010, 32)            = -1 EBADF (Bad file descriptor)
read(-2, 0x7ffcbab09010, 32)            = -1 EBADF (Bad file descriptor)
...
read(-2, 0x7ffcbab09010, 32)            = -1 EBADF (Bad file descriptor)
read(-2, 0x7ffcbab09010, 32)            = -1 EBADF (Bad file descriptor)
$ sandboxed-tor-browser -version
sandboxed-tor-browser 0.0.12-dev (26c9478)
$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.1 (stretch)
Release:        9.1
Codename:       stretch

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by yawning

Resolution: duplicate
Status: newclosed

Duplicate of #22853

comment:2 Changed 2 years ago by yawning

Resolution: duplicate
Status: closedreopened

Oh. The browser developers didn't pull in the version of selfrando where they figured out how calling conventions worked, even though they told me they will, so I only applied the workaround for 7.5a2 and lower.

comment:3 Changed 2 years ago by yawning

Resolution: fixed
Status: reopenedclosed

https://gitweb.torproject.org/tor-browser/sandboxed-tor-browser.git/commit/?id=2262bf1843129feddb7a913b15ef6298be71f4c1

Surely the next alpha build will have a SelfRando that doesn't do something totally idiotic.

Note: See TracTickets for help on using tickets.