Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#2306 closed defect (fixed)

tor-0.2.2.20-alpha and 0.2.1.28 are missing openbsd malloc

Reported by: Falo Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

./configure --prefix=/ --disable-asciidoc --enable-openbsd-malloc
make

stops with "No rule to make target `OpenBSD_malloc_Linux.o'"

attached you'll find configure and make output.

Child Tickets

Attachments (2)

typescript (24.2 KB) - added by Falo 9 years ago.
typescript.2 (18.7 KB) - added by Falo 9 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by Sebastian

Resolution: duplicate
Status: newclosed

Duplicate of #2305

comment:2 Changed 9 years ago by Falo

Resolution: duplicate
Status: closedreopened

Changed 9 years ago by Falo

Attachment: typescript added

Changed 9 years ago by Falo

Attachment: typescript.2 added

comment:3 Changed 9 years ago by arma

Summary: tor-0.2.2.20-alpha doesn't compile on Debian x86_64tor-0.2.2.20-alpha and 0.2.1.28 are missing openbsd malloc

comment:4 Changed 9 years ago by arma

Nothing really to fix here, except that next time I should do the 'make dist' on moria, where the autofoo tools are configured correctly, rather than on a laptop I used since we didn't want to push any of the patches until packages were ready.

Recommended workaround in the mean time is to stop wanting openbsd-malloc.

comment:5 Changed 9 years ago by Falo

ok, I'll give it a try. In the past Tor being built without openbsd-malloc leaked like hell. --enable-openbsd-malloc is still a valid config option.

comment:6 Changed 9 years ago by xsappyx

copying tor-0.2.1.26/src/common/OpenBSD_malloc_Linux.c to tor-0.2.1.28/src/common let 2.1.28 build and run with --enable-openbsd-malloc

comment:7 in reply to:  6 Changed 9 years ago by Falo

Replying to xsappyx:

copying tor-0.2.1.26/src/common/OpenBSD_malloc_Linux.c to tor-0.2.1.28/src/common let 2.1.28 build and run with --enable-openbsd-malloc

ok, just did it.

Using malloc() from glibc really doesn't work for me. After two days of operation process size was about 1,3 Gig.

comment:8 Changed 9 years ago by nickm

Resolution: fixed
Status: reopenedclosed

This should be better in the next releases: I've made it so that our package build process notes that it needs automake 1.7 or later , so that we won't accidentally leave openbsd_malloc out in a later release. (See notes for bug #2305 and commit e4320689cc468).

Also, this bug was a duplicate. Please don't reopen duplicates.

comment:9 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:10 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.