Opened 9 years ago

Closed 9 years ago

#2311 closed defect (not a bug)

extraneous website files not in svn?

Reported by: arma Owned by: phobos
Priority: Medium Milestone:
Component: Webpages/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The output of my 'publish' script starts with:

cannot delete non-empty directory: torvm
cannot delete non-empty directory: tordnsel
rsync: delete_file: unlink(project/trace/www-master.torproject.org) failed: Permission denied (13)
cannot delete non-empty directory: project/trace
cannot delete non-empty directory: project/trace
cannot delete non-empty directory: project
deleting sitemap.html.en

So a) should we put a "project" directory into svn, and generate the trace file? When did we stop doing that?

b) What's the story with torvm and tordnsel? Andrew removed them from svn, but I guess not from the website.

c) Who made sitemap.html.en and should we put it in svn?

I'm guessing phobos knows the answers to these questions.

Child Tickets

Change History (2)

comment:1 in reply to:  description Changed 9 years ago by phobos

Status: newaccepted

Replying to arma:

The output of my 'publish' script starts with:

cannot delete non-empty directory: torvm
cannot delete non-empty directory: tordnsel
rsync: delete_file: unlink(project/trace/www-master.torproject.org) failed: Permission denied (13)
cannot delete non-empty directory: project/trace
cannot delete non-empty directory: project/trace
cannot delete non-empty directory: project
deleting sitemap.html.en

I don't see these errors in my publish.

So a) should we put a "project" directory into svn, and generate the trace file? When did we stop doing that?

The trace file is generated by the webserver mirror script automatically.

b) What's the story with torvm and tordnsel? Andrew removed them from svn, but I guess not from the website.

I removed torvm from the website. tordnsel is still live as far as I know. We still rely on it for check.tpo.

c) Who made sitemap.html.en and should we put it in svn?

I did as the 404 handler, and then we decided not to use it, so I removed it. I don't have a sitemap.wml in my svn repo. Perhaps wipe your repo and check it out clean? You seem to have a lot of old stuff hanging around.

comment:2 Changed 9 years ago by phobos

Resolution: not a bug
Status: acceptedclosed
Note: See TracTickets for help on using tickets.