Opened 2 years ago

Closed 4 weeks ago

#23142 closed defect (fixed)

HTML <marquee> elements are broken on goftesh.com in Tor Browsr

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability-website
Cc: mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It seems Tor Browser is breaking <marquee> elements somehow. This got reported on our blog (https://blog.torproject.org/comment/270124#comment-270124) the example being goftesh.com

This works in Firefox 52 ESR. I flipped the first-party isolation pref and things are still working in Firefox 52 ESR. Disabling NoScript, HTTPS-E and Torbutton in Tor Browser does not solve the problem. Looking back in history this seems to be a bug already included in old Tor Browser versions. I tested Tor Browser 4.0 and there the <marquee> element is broken as well.

Child Tickets

Change History (4)

comment:1 Changed 2 years ago by mcs

Cc: mcs added

Here is a simpler test page: https://pearlcrescent.com/tor/marquee.html

On OSX it works after I disable Torbutton but I do not know which part of Torbutton is interfering with the <marquee> tag. Maybe we are doing people a favor by breaking it :)

comment:2 Changed 2 years ago by mcs

Status: newneeds_information

Flipping extensions.torbutton.resource_and_chrome_uri_fingerprinting to true fixes this problem. The root cause is that our content policy filter blocks the load of chrome://xbl-marquee/content/xbl-marquee.xml Should we whitelist that URL?

comment:3 Changed 2 years ago by gk

Aha, interesting. I think we should look whether that would enabled some platform detection but if not, we should add the URL to the whitelist. Surprisingly, your fix does not help with the original bug report (see description). But my guess would be that this is another fallout from Cloudflare's fuck-up (see #21341).

Version 0, edited 2 years ago by gk (next)

comment:4 Changed 4 weeks ago by gk

Resolution: fixed
Status: needs_informationclosed

We don't have a content policy filter anymore after the fix landed in Firefox and the scrolling does indeed working now on the chat website.

Note: See TracTickets for help on using tickets.