Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2318 closed defect (wontfix)

Tor dies after you quit Vidalia on Mac

Reported by: aaronsw Owned by: chiiph
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I installed the Mac version of Tor and opened Vidalia. While it was open, I was able to use Tor just fine. But when I quit out, I was no longer able to use Tor.

Obviously I could keep it open all the time, but it's annoying to have an extra icon in the dock and menu bar.

I would much prefer if Tor would start up on boot and I could open Vidalia to control it, but it would keep running even after I quit Vidalia.

Child Tickets

Change History (3)

comment:1 in reply to:  description Changed 9 years ago by rransom

Resolution: wontfix
Status: newclosed

Replying to aaronsw:

I installed the Mac version of Tor and opened Vidalia. While it was open, I was able to use Tor just fine. But when I quit out, I was no longer able to use Tor.

This is the intended behaviour. When Vidalia starts Tor, it configures Tor so that only the instance of Vidalia that started it can control it. If Vidalia did not end its instance of Tor, most users would not be able to end that instance of Tor, and Vidalia would not work again until the computer is rebooted.

I would much prefer if Tor would start up on boot and I could open Vidalia to control it, but it would keep running even after I quit Vidalia.

See #2308 for how to configure an instance of Tor started at boot so that Vidalia can control it. You will need to compile Tor and figure out how to start it yourself.

comment:2 Changed 9 years ago by Sebastian

You don't actually need to compile it yourself, you can use the Tor instance in /Applications/Vidalia.app/Contents/MacOS/tor. You should learn about launchd/launchtl to see how to start it automatically at boot.

comment:3 Changed 9 years ago by arma

Component: VidaliaTor bundles/installation

Up until recently we provided "expert" packages for OS X, which just had Tor in them. But they became a hassle to maintain, especially as we were introducing the Tor Browser Bundle OS X bundles, so we stopped a month or so back.

But yes, if you want your Tor to act like a daemon on your BSD-like system, grab the Tor binary and debian's init script and go to it. Or use the more osx-style launchd approach -- if you can get that to work, we'd love to learn how you did it.

Note: See TracTickets for help on using tickets.