Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#23209 closed defect (not a bug)

When I opened Tor Launcher and changed my pluggable transport to snowflake a message from my firewall popped up

Reported by: Dbryrtfbcbhgf Owned by: tbb-team
Priority: Medium Milestone:
Component: Circumvention/Snowflake Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I opened Tor Launcher and changed my pluggable transport to snowflake a message from my firewall popped up, it said "do you want to allow snowflake-client to allow incoming connections", some users may be concerned because this message has never popped up when using Tor Browser Bundle.

TBB 7.5a4

Child Tickets

Attachments (1)

bug.png (33.5 KB) - added by Dbryrtfbcbhgf 2 years ago.

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by Dbryrtfbcbhgf

Attachment: bug.png added

comment:1 Changed 2 years ago by gk

Resolution: not a bug
Status: newclosed

That's part of the inner snowflake workings, see e.g. https://lists.torproject.org/pipermail/tor-dev/2016-January/010310.html and https://trac.torproject.org/projects/tor/wiki/doc/Snowflake. I think there is not much we can do about your issue in Tor Browser.

comment:2 Changed 2 years ago by dcf

Component: Applications/Tor BrowserObfuscation/Snowflake

Thanks for trying Snowflake.

I'm not 100% sure why the popup appears on macOS--I think it has something to do with the UDP socket the client creates for the WebRTC connection. We may be able to get rid of it, or we may not. But if we cannot, then we need to at least mention it in our tutorials (it surprised me too when I saw it the first time).

Note: See TracTickets for help on using tickets.