Opened 15 months ago

Closed 8 months ago

#23234 closed defect (duplicate)

Possible problem with bootstrapping logic (Problem bootstrapping. Stuck at 53%: Loading relay descriptors. (No route to host; NOROUTE; count 7; recommendation warn)

Reported by: s7r Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: unspecified
Severity: Normal Keywords: bootstrap, dirguard, bridge, needs-insight, 031-backport, 033-triage-20180320, 033-removed-20180320
Cc: Actual Points:
Parent ID: #21969 Points:
Reviewer: Sponsor:

Description

After an upgrade to latest git master Tor 0.3.2.0-alpha-dev (git-257f50b22fbaf9c9) got some bootstrapping complaints that seam to be triggered by the DirGuard being offline. This is a bridge, and was taken offline few days ago by a power failure. The hard drive was not affected so the files in datadirectory were kept.

Aug 14 00:28:57.000 [notice] Starting with guard context "default"
Aug 14 00:28:57.000 [notice] Bootstrapped 45%: Asking for relay descriptors
Aug 14 00:28:57.000 [warn] Problem bootstrapping. Stuck at 45%: Asking for relay descriptors. (No route to host; NOROUTE; count 1; recommendation warn; host 5EB8D862E70981B8690DEDEF546789E26AB2BD24 at 109.163.234.5:443)
Aug 14 00:28:58.000 [warn] Problem bootstrapping. Stuck at 45%: Asking for relay descriptors. (No route to host; NOROUTE; count 3; recommendation warn; host 5EB8D862E70981B8690DEDEF546789E26AB2BD24 at 109.163.234.5:443)
Aug 14 00:28:58.000 [warn] 2 connections have failed:
Aug 14 00:28:58.000 [warn]  2 connections died in state connect()ing with SSL state (No SSL object)
Aug 14 00:28:58.000 [warn] Problem bootstrapping. Stuck at 45%: Asking for relay descriptors. (No route to host; NOROUTE; count 4; recommendation warn; host 5EB8D862E70981B8690DEDEF546789E26AB2BD24 at 109.163.234.5:443)
Aug 14 00:28:58.000 [warn] 3 connections have failed:
Aug 14 00:28:58.000 [warn]  3 connections died in state connect()ing with SSL state (No SSL object)
Aug 14 00:28:58.000 [notice] Bootstrapped 53%: Loading relay descriptors
Aug 14 00:28:58.000 [warn] Problem bootstrapping. Stuck at 53%: Loading relay descriptors. (No route to host; NOROUTE; count 2; recommendation warn; host 5EB8D862E70981B8690DEDEF546789E26AB2BD24 at 109.163.234.5:443)
Aug 14 00:28:58.000 [warn] 5 connections have failed:
Aug 14 00:28:58.000 [warn]  5 connections died in state connect()ing with SSL state (No SSL object)
Aug 14 00:28:58.000 [warn] Problem bootstrapping. Stuck at 53%: Loading relay descriptors. (No route to host; NOROUTE; count 4; recommendation warn; host 5EB8D862E70981B8690DEDEF546789E26AB2BD24 at 109.163.234.5:443)
Aug 14 00:28:58.000 [warn] 7 connections have failed:
Aug 14 00:28:58.000 [warn]  7 connections died in state connect()ing with SSL state (No SSL object)
Aug 14 00:28:58.000 [warn] Problem bootstrapping. Stuck at 53%: Loading relay descriptors. (No route to host; NOROUTE; count 6; recommendation warn; host 5EB8D862E70981B8690DEDEF546789E26AB2BD24 at 109.163.234.5:443)
Aug 14 00:28:58.000 [warn] 9 connections have failed:
Aug 14 00:28:58.000 [warn]  9 connections died in state connect()ing with SSL state (No SSL object)
Aug 14 00:28:58.000 [warn] Problem bootstrapping. Stuck at 53%: Loading relay descriptors. (No route to host; NOROUTE; count 7; recommendation warn; host 5EB8D862E70981B8690DEDEF546789E26AB2BD24 at 109.163.234.5:443)
Aug 14 00:28:58.000 [warn] 10 connections have failed:
Aug 14 00:28:58.000 [warn]  10 connections died in state connect()ing with SSL state (No SSL object)

The complaints stop when Bootstrap reaches 80%, but the "missing descriptors from some of our primary entry guards" follows immediately:

Aug 14 00:29:10.000 [notice] Bootstrapped 80%: Connecting to the Tor network
Aug 14 00:29:10.000 [notice] Bootstrapped 85%: Finishing handshake with first hop
Aug 14 00:29:11.000 [notice] Bootstrapped 90%: Establishing a Tor circuit
Aug 14 00:29:12.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Aug 14 00:29:12.000 [notice] Bootstrapped 100%: Done
Aug 14 00:29:12.000 [notice] Now checking whether ORPort xx.br.id.ge:yy is reachable... (this may take up to 20 minutes -- look for log messages indicating success)
Aug 14 00:29:13.000 [notice] Our directory information is no longer up-to-date enough to build circuits: We're missing descriptors for some of our primary entry guards
Aug 14 00:29:13.000 [notice] I learned some more directory information, but not enough to build a circuit: We're missing descriptors for some of our primary entry guards
Aug 14 00:29:13.000 [notice] We now have enough directory information to build circuits.
Aug 14 00:29:13.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Aug 14 00:29:13.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.

One problem is: How come it just bootstrapped 100%, and 1 second later Tor realizes it is missing descriptors for some of our primary guards?

Second: Why does it report no route to host and SSL connections failing in state connect if the internet connection is working good and the problem is just at the endpoint? Even if the problem is not at the endpoint this particular log message is awfully confusing.

Child Tickets

Change History (10)

comment:1 in reply to:  description Changed 15 months ago by arma

Replying to s7r:

Second: Why does it report no route to host and SSL connections failing in state connect if the internet connection is working good and the problem is just at the endpoint? Even if the problem is not at the endpoint this particular log message is awfully confusing.

Well, this one I can answer.

$ telnet 109.163.234.5 443
Trying 109.163.234.5...
telnet: connect to address 109.163.234.5: No route to host

comment:2 Changed 15 months ago by catalyst

Keywords: bootstrap added

comment:3 Changed 15 months ago by nickm

Keywords: dirguard bridge needs-insight 031-backport added

comment:4 Changed 12 months ago by teor

Parent ID: #21969

This will probably be resolved when we fix #21969.

comment:5 Changed 11 months ago by asn

Milestone: Tor: 0.3.2.x-finalTor: 0.3.3.x-final

comment:6 Changed 8 months ago by nickm

Keywords: 033-triage-20180320 added

Marking all tickets reached by current round of 033 triage.

comment:7 Changed 8 months ago by nickm

Keywords: 033-removed-20180320 added

Mark all not-already-included tickets as pending review for removal from 0.3.3 milestone.

comment:8 Changed 8 months ago by nickm

Milestone: Tor: 0.3.3.x-finalTor: unspecified

These tickets were marked as removed, and nobody has said that they can fix them. Let's remember to look at 033-removed-20180320 as we re-evaluate our triage process, to see whether we're triaging out unnecessarily, and to evaluate whether we're deferring anything unnecessarily. But for now, we can't do these: we need to fix the 033-must stuff now.

comment:9 in reply to:  4 Changed 8 months ago by arma

Replying to teor:

This will probably be resolved when we fix #21969.

Agreed. In fact, it might even be called a duplicate of it.

comment:10 Changed 8 months ago by teor

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.