Opened 10 months ago

Closed 9 months ago

#23253 closed defect (not a bug)

BridgeAuth goes offline when it has an expired ed25519_signing_cert

Reported by: isis Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-bridgeauth, tor-dirauth, tor-ed25519-keys
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor: SponsorM-can

Description

However, Roger says in IRC that the BridgeAuth doesn't use (or shouldn't be using) this key, since it's only for v3 DirAuths.

Child Tickets

Change History (3)

comment:1 Changed 10 months ago by arma

Ah ha -- no, it's the authority_signing_key that I said was only for v3 auths. And I still think that's true.

But the ed25519_signing_cert file is for every relay. It has nothing to do with your bridge authority status in particular.

You have a relay whose signing key (for the relay, not for any authority thing) has just expired. I guess that means you made your relay identity key in an offline way? You need to do whatever the process is for generating a new signing cert from your ed25519_signing_secret_key.

Last edited 10 months ago by arma (previous) (diff)

comment:2 Changed 10 months ago by nickm

Milestone: Tor: 0.3.2.x-final
Status: newneeds_information

Is this a bug?

comment:3 Changed 9 months ago by nickm

Resolution: not a bug
Status: needs_informationclosed
Note: See TracTickets for help on using tickets.