Opened 5 weeks ago

Closed 5 weeks ago

Last modified 3 weeks ago

#23270 closed enhancement (invalid)

Allow Tor relays to be configured to block selected hidden services, including racist hate sites

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: racism, hate, anti-fascism, probably-bad-idea, slippery-slope,
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by nickm)

We are glad that tor project has spoken out against racist hate speech sites but talk is cheap.

Tor routers stil advertize hate sites like "--.onion". Please include this url as blocked in the default configuration so that routers will not broadcast it.

Child Tickets

Change History (26)

comment:1 Changed 5 weeks ago by pastly

Code like that doesn't exist and probably shouldn't exist.

Insert slippery slope argument focused on Tor being coerced into censoring arbitrary onion services.

comment:2 Changed 5 weeks ago by cypherpunks

This will be easy to implement. Just a list of a strings to check against before broadcasting. It could also use salted hashing to make the .onion domains secret.

People who think they are doing a good service by running tor routers are literally helping spread violent hate speech.

The purpose of tor project is not to make life easy for fascists.

comment:3 Changed 5 weeks ago by pastly

The purpose of the Tor Project is also not to make life easy for the people using Tor for other things you/I disagree with. But it is an unfortunate reality of actually useful software.

comment:4 Changed 5 weeks ago by cypherpunks

Wrong. The point of Tor is to be a force for good. People use Tor for many unsavory things, but none of them have even remotely the destructive potential of fascism. It is unarguably evil, there is no literally no argument in favor of allowing them to use Tor to spread their violent speech others. I would propose, at a bare minimum, a torrc option allowing Tor relays to specify the addresses of .onion addresses that they do not wish to advertise via their relay. This way, Tor volunteers can at least decide for themselves that they do not wish to be complicit in evil by helping to spread fascism and hate speech.

comment:5 Changed 5 weeks ago by catalyst

Component: Core TorCore Tor/Tor
Milestone: Tor: unspecified
Status: newneeds_information

There are many better ways to oppose fascism than by making our code censor-friendly. (and a number of Tor people already do these things) If you can think of a plausible way to change the code to make it harder for fascists to use Tor without also making it easier for someone to silence the people the fascists want to harm, I would be pleasantly surprised.

comment:6 Changed 5 weeks ago by cypherpunks

It's not censorship to refuse to publish hate. Tor project opposes the daily stormer, please see here https://twitter.com/torproject/status/898256109789687808

It's time to take action.

comment:7 Changed 5 weeks ago by cypherpunks

If you can think of a plausible way to change the code to make it harder for fascists to use Tor without also making it easier for someone to silence the people the fascists want to harm

I can definitely think of one way - by letting Tor relay operators choose for themselves whether they want to actively disseminate violent speech. Democracy is our only protection against fascism - why should Tor not be run more democratically, by letting relay operators decide what services they want to implicitly endorse by allowing their own relays to advertise for?

It's ridiculous that we even have to have this discussion - I and many other people I know run Tor relays, why should we be forced to spread the hateful and violent message of Daily Stormer and their ilk? This feature should have implemented from day one.

Why does Tor Project bother with the worthless virtue signaling if it won't put its money where its mouth is and take action? Why won't it give power to its volunteers by letting them decide democratically if they want to take a stand against evil?

I guess talk really is cheap.

Last edited 5 weeks ago by cypherpunks (previous) (diff)

comment:8 Changed 5 weeks ago by cypherpunks

Resolution: invalid
Status: needs_informationclosed

You just do not get Free Open Source Software, do you? Users own the right to edit the software as they please. Tor Project has no ability to control what sites people can host and access. Relay operators have no ability to either. This is permanently baked into the design.

Best to completely forget about the whole blog post, it was a very stupid idea, one very new person decided in haste, and doesn't speak for everyone in the Tor community. Speech may be unpleasant, even "dangerous", but it is still free speech.

Tor is an anonymity network and in reality has nothing to do with human rights one way or another except the right to privacy.

comment:9 Changed 5 weeks ago by atagar

It's ridiculous that we even have to have this discussion - I and many other people I know run Tor relays, why should we be forced to spread the hateful and violent message of Daily Stormer and their ilk?

Hi cypherpunks. I hear ya and I was certainly irked when I heard those assholes where moving onto our network. I certainly don't want to shut down the discussion and by all means feel free to brainstorm options but for what it's worth the trouble isn't that we *want* to empower jerks. The 'problem' (if you can call it that) is that tor aims to provide truly strong anonymity. Relays service content without knowing if it's hate speech verses Chinese dissidents. You can't block one group without ruining privacy the tool gives to everyone.

Back doors and impairing user anonymity is absolutely a road we will not consider. That said, if you'd care to propose options that empower relay operators in a way that does not impair those then by all means - happy to hear ideas.

I probably won't take part further on this ticket (hidden service design isn't my area of expertise) but just wanted to leave a note since I was pissed about them too.

Last edited 5 weeks ago by atagar (previous) (diff)

comment:10 Changed 5 weeks ago by cypherpunks

You just do not get Free Open Source Software, do you? Users own the right to edit the software as they please. Tor Project has no ability to control what sites people can host and access. Relay operators have no ability to either. This is permanently baked into the design.

Free software has always been political. Yes, Nazis would just remove the code but then a racist has to keep hitting reload until they reach a nazi-run tor router that removed that code. It might not 100% stop them in their tracks but I support anything that makes life harder for them and puts resistance in their way.

Many other projects like EFF and guardian project have agreed with the tor post about this violent speech being unacceptable. What changes do you propose to limit it? or are you simply here to defend fascism?

Last edited 5 weeks ago by cypherpunks (previous) (diff)

comment:11 in reply to:  7 Changed 5 weeks ago by catalyst

Replying to cypherpunks:

Why does Tor Project bother with the worthless virtue signaling if it won't put its money where its mouth is and take action? Why won't it give power to its volunteers by letting them decide democratically if they want to take a stand against evil?

People are taking actions. Many of them don't involve writing code. Some of the actions are ones you might not see or acknowledge.

comment:12 Changed 5 weeks ago by cypherpunks

People are of course free to condemn the speech of Nazis, or any other group with whom they disagree, and that is exactly what the author of the blog post was doing. Censorship is impossible by design, as well as being against everything we stand for, especially free speech without exceptions. It will never happen.

comment:13 Changed 5 weeks ago by nickm

Description: modified (diff)
Keywords: probably-bad-idea slippery-slope but-its-the-good-kind-of-censorship added
Summary: Please stop tor routers from advertising racist hate websitesAllow Tor relays to be configured to block selected hidden services, including racist hate sites

We can't build anticensorship tools with censorship features, since doing so puts everyone at risk. I'll try to explain why.

(Before I go into it, though, let's reflect on how desperate these racist scumbags are, to be using a service written and operated by folks like you and me. What losers! If they really believed they were the "superior race", they'd try to write their own cryptography like the real nazis did, rather than relying on a mixed group of "degenerates" like us.)

You describe a solution where hidden service directories can block whatever their operators believe should be blocked. I think this would not have the results you want, for quite a few reasons. I'll try to put a few of them down in one place, so I can link to it when I want to in the future.

  1. It doesn't do what you want. Even if you had a list of hidden service descriptors you wouldn't serve, you'd still get used as an introduction point or a rendezvous point.
  2. It doesn't block the service until *every* HSDir corresponding to the service on the hash ring blocks it. The loser scumbags' website would be up more than 50% of the time, even if you got 90% of the relay operators to all block it. (And there's no way you can get 90% of relay operators to agree to anything.)
  3. It only works until the stupid racist bastards change their .onion address. The censoring relays would need to find mirrors and automatically add the mirrors to their blacklists. This requires an increasingly elaborate and centralized mechanism, which is not what you say you want.
  4. It has potential, in some jurisdictions, to open relay operators to legal liability for things that they choose _not_ to censor. (IANAL, TINLA)
  5. The directory authorities would need to decide how much a relay can censor before it is not suitable for use as an hsdir. This undoes the supposed democracy of the situation, _and_ puts the directory authorities into the role of censor-censors. Again, centralization.
  6. When censorship is possible and routine, censorship is far more easily compelled.

Of course, maybe you could try to design a censorship tool that didn't have these problems! But I think you'd find it pretty challenging. It's hard enough to build an anticensorship network.

I'm also going to edit your post to take out the link, and to reflect the feature you are requesting. If you believe what you say you believe, you should not link to nazi sites. They like it when you do that.

(Also, my apologies if I have let any brusque tone come through, but: there have been a lot of people trolling us over the past few days, pretending to be things that they are not, many of them using jargon that's atypical for their professed positions. I've run into arguments like this a lot over and over in different places, and often, after having responded in good faith, I found out that I've been trolled. This kinda makes me short-tempered with this stuff. If you want a good-faith discussion, maybe get in touch by some other means (so that trolls can't impersonate you), and stop accusing us of bad faith in all your messages. When you do that, it makes it hard for the folks you're accusing to keep a level head.)

comment:14 in reply to:  10 Changed 5 weeks ago by cypherpunks

Replying to cypherpunks:

You just do not get Free Open Source Software, do you? Users own the right to edit the software as they please. Tor Project has no ability to control what sites people can host and access. Relay operators have no ability to either. This is permanently baked into the design.

Free software has always been political. Yes, Nazis would just remove the code but then a racist has to keep hitting reload until they reach a nazi-run tor router that removed that code. It might not 100% stop them in their tracks but I support anything that makes life harder for them and puts resistance in their way.

Doing that would be inefficient. If an onion address is censored, a new one can be created within minutes. And racists don't need an onion web site to communicate their ideas anyway. I never ever visited any racist onion site, but I still see racist comments everywhere in the newspapers, on TV, radio, and basically everywhere. Who cares about racist comments on an unknown onion site when the president of the United States openly shares his racist ideas on TV. Closing this particular racist onion site will not achieve anything.

More than being inefficient it will make Tor useless. If we get in a position where someone is able to control what is published, then the next step is to ask them to censor this other bad topic that is really really bad, and them make them responsible for anything that they decided not to censor.

Many other projects like EFF and guardian project have agreed with the tor post about this violent speech being unacceptable. What changes do you propose to limit it? or are you simply here to defend fascism?

There are many things to do, but destroying Tor by integrating censorship features is certainly not one of them.

comment:15 Changed 5 weeks ago by cypherpunks

If an onion address is censored, a new one can be created within minutes

then all the nazis following this site have to go work hard to find the new address. they don't have a twitter account anymore so it's not easy for them to just look it up. Yes, sure it's possible to get around it but making life harder for nazis and slowing them down is a net good for the world. You complained about US politics, how do you think that situation happened? people like these sharing their toxic rhetoric online.

If we get in a position where someone is able to control what is published, then the next step is to ask them to censor this other bad topic that is really really bad, and them make them responsible for anything that they decided not to censor.

It's not censorship to choose not to publish someones illegal, violent hateful screeds.

Anybody who runs a tor router is running the risk of (A) directly telling other nodes where to find this disgusting content (B) their computer actually help passing it through their computer. If the tor project really cares about this, as they have explicitly stated they do, then they should be doing something to put a stop to this. No air for fascists.

comment:16 in reply to:  15 Changed 5 weeks ago by cypherpunks

Replying to cypherpunks:

If an onion address is censored, a new one can be created within minutes

then all the nazis following this site have to go work hard to find the new address. they don't have a twitter account anymore so it's not easy for them to just look it up. Yes, sure it's possible to get around it but making life harder for nazis and slowing them down is a net good for the world. You complained about US politics, how do you think that situation happened? people like these sharing their toxic rhetoric online.

What I'm saying is that they don't need Tor to share their toxic ideas, online or offline. Destroying Tor so they cannot use it to share their toxic ideas will not stop them from continuing what they are doing, it will just remove tor from the list of tools that good people can use.

If we get in a position where someone is able to control what is published, then the next step is to ask them to censor this other bad topic that is really really bad, and them make them responsible for anything that they decided not to censor.

It's not censorship to choose not to publish someones illegal, violent hateful screeds.

Nobody choose to publish anything, except the owner of the onion site.

comment:17 Changed 5 weeks ago by cypherpunks

It's not censorship to choose not to publish

Importantly, Tor is not a hosting platform and does not publish what people say on websites, any more than the air publishes what someone says in person.

Incidentally how often do you see censors call censorship, censorship? It's always "not censorship". If the US president decided to order Tor to censor political opponents, it would be equally impossible to comply then. Be glad of it.

comment:18 in reply to:  13 ; Changed 5 weeks ago by cypherpunks

Replying to nickm:

We can't build anticensorship tools with censorship features, since doing so puts everyone at risk. I'll try to explain why.

(Before I go into it, though, let's reflect on how desperate these racist scumbags are, to be using a service written and operated by folks like you and me. What losers! If they really believed they were the "superior race", they'd try to write their own cryptography like the real nazis did, rather than relying on a mixed group of "degenerates" like us.)

You describe a solution where hidden service directories can block whatever their operators believe should be blocked. I think this would not have the results you want, for quite a few reasons. I'll try to put a few of them down in one place, so I can link to it when I want to in the future.

  1. It doesn't do what you want. Even if you had a list of hidden service descriptors you wouldn't serve, you'd still get used as an introduction point or a rendezvous point.

My understanding of the rendezvous specification is that introduction points are also given the public key of the OP which is trying to advertise through them. Couldn't ORs match against these, as well as HSDirs?

  1. It doesn't block the service until *every* HSDir corresponding to the service on the hash ring blocks it. The loser scumbags' website would be up more than 50% of the time, even if you got 90% of the relay operators to all block it. (And there's no way you can get 90% of relay operators to agree to anything.)

While it would be great if sites that spew hate couldn't exist at all on Tor, I realize that blocking a site entirely is not feasible. What does seem feasible to me, however, is giving relay operators the power to decide for themselves if they want to be a part of spreading their hateful message. It's only when we all work together that we can fight fascism. Increasing their downtime, even by just a little, would be a huge help.

  1. It only works until the stupid racist bastards change their .onion address. The censoring relays would need to find mirrors and automatically add the mirrors to their blacklists. This requires an increasingly elaborate and centralized mechanism, which is not what you say you want.

Again, blocking entirely I know is not feasible, but it does make things difficult for them. Perhaps relay operators could subscribe to a service which provides a list of known hate-speech websites, which are then automatically blocked on their relay (as a HSDir and as an introduction point). Either way, it generates work to be done on their end. Every little bit helps.

  1. It has potential, in some jurisdictions, to open relay operators to legal liability for things that they choose _not_ to censor. (IANAL, TINLA)

I don't think this is a serious concern, any more than the concern that they might be found liable even without such a change being made to Tor. In any event, I think that the goal, which is to fight fascism, is more important - it is a clear and present danger right now, and without it, Tor cannot exist. Fascists will obviously not allow Tor to operate if they gain power.

  1. The directory authorities would need to decide how much a relay can censor before it is not suitable for use as an hsdir. This undoes the supposed democracy of the situation, _and_ puts the directory authorities into the role of censor-censors. Again, centralization.

I don't see anyone blocking more than the small minority of hate speech websites on Tor.

  1. When censorship is possible and routine, censorship is far more easily compelled.

See above.

Some censorship is always necessary - such as to prevent the spread of ideas (like fascism) that threaten the very existence of institutions that are dedicated to free speech (like Tor). Do you think these fascists are going to let people run Tor if they got in power?

Of course, maybe you could try to design a censorship tool that didn't have these problems! But I think you'd find it pretty challenging. It's hard enough to build an anticensorship network.

I'm also going to edit your post to take out the link, and to reflect the feature you are requesting. If you believe what you say you believe, you should not link to nazi sites. They like it when you do that.

It's very frustrating to me that you're not seriously considering this, as evidenced by the fact that you added the obviously-sarcastic "but-its-the-good-kind-of-censorship" tag. Recently Tor project published a blog post which took a stand against hate speech. It's easy to see why - the rise of fascism in America and Europe is real and measurable, and has been terrifyingly visible recently. What, then, is Tor Project, the new home of these violent cretins, actually going to do about it? It's easy to nay-say and turn your nose up at things, but then, what real alternative is there? I can't understate the seriousness of this - all of us who value freedom and democracy need to take action against these fascists now, because once they take power, we certainly won't be able to use Tor to organize against them (see: China, for example, where Tor usage is only possible through the altruism of Tor bridge operators from other countries).

(Also, my apologies if I have let any brusque tone come through, but: there have been a lot of people trolling us over the past few days, pretending to be things that they are not, many of them using jargon that's atypical for their professed positions. I've run into arguments like this a lot over and over in different places, and often, after having responded in good faith, I found out that I've been trolled. This kinda makes me short-tempered with this stuff. If you want a good-faith discussion, maybe get in touch by some other means (so that trolls can't impersonate you), and stop accusing us of bad faith in all your messages. When you do that, it makes it hard for the folks you're accusing to keep a level head.)

Last edited 5 weeks ago by cypherpunks (previous) (diff)

comment:19 in reply to:  8 Changed 5 weeks ago by cypherpunks

Replying to cypherpunks:

You just do not get Free Open Source Software, do you? Users own the right to edit the software as they please. Tor Project has no ability to control what sites people can host and access. Relay operators have no ability to either. This is permanently baked into the design.

Best to completely forget about the whole blog post, it was a very stupid idea, one very new person decided in haste, and doesn't speak for everyone in the Tor community. Speech may be unpleasant, even "dangerous", but it is still free speech.

The blog post is actually saying the same thing as you:
Tor is designed to defend human rights and privacy by preventing anyone from censoring things, even us.

comment:20 in reply to:  18 Changed 5 weeks ago by alison

Let me first say that I understand your frustration and desperation about this, anon cypherpunk. As a core contributor to Tor Project and an ardent anti-fascist, I feel horror and disgust knowing that fascists are using software that I care about deeply. Please give us the benefit of the doubt as people who are in solidarity in this fight.

While it would be great if sites that spew hate couldn't exist at all on Tor, I realize that blocking a site entirely is not feasible. What does seem feasible to me, however, is giving relay operators the power to decide for themselves if they want to be a part of spreading their hateful message. It's only when we all work together that we can fight fascism. Increasing their downtime, even by just a little, would be a huge help.

I urge you to consider the unintended consequences that would result from this. What would stop fascists from running as many relays as possible and then blocking access to antifascist onions? The people who are actually at risk for serious censorship, like going to prison for speech, are people who oppose fascism. The Department of Justice just requested 1.3 million IP addresses from an anti-Trump website. Consider that it may only be a matter of time before those sites need to operate from onions. As nickm and others have said, if we create conditions where relay operators can be compelled to censor onion sites, it will not produce the outcomes that you desire.

  1. It only works until the stupid racist bastards change their .onion address. The censoring relays would need to find mirrors and automatically add the mirrors to their blacklists. This requires an increasingly elaborate and centralized mechanism, which is not what you say you want.

Again, blocking entirely I know is not feasible, but it does make things difficult for them. Perhaps relay operators could subscribe to a service which provides a list of known hate-speech websites, which are then automatically blocked on their relay (as a HSDir and as an introduction point). Either way, it generates work to be done on their end. Every little bit helps.

Again, how do you prevent this from being weaponized against others?

  1. It has potential, in some jurisdictions, to open relay operators to legal liability for things that they choose _not_ to censor. (IANAL, TINLA)

I don't think this is a serious concern, any more than the concern that they might be found liable even without such a change being made to Tor. In any event, I think that the goal, which is to fight fascism, is more important - it is a clear and present danger right now, and without it, Tor cannot exist. Fascists will obviously not allow Tor to operate if they gain power.

Well, they're already in power in many places, including in the US. How are legal liabilities not a serious concern if fascism is on the rise? Fascism operates in part through increased "law and order", that is to say increased policing.

I agree with the Paradox of Tolerance that open societies condemn themselves by allowing space for intolerant views, but while I see ways to address this on a human level, I fail to see how you can build technology that only censors what you want to see censored. If you can conceive of a way to do this that won't be weaponized against the people who fascism seeks to further marginalize, then patches welcome.

  1. The directory authorities would need to decide how much a relay can censor before it is not suitable for use as an hsdir. This undoes the supposed democracy of the situation, _and_ puts the directory authorities into the role of censor-censors. Again, centralization.

I don't see anyone blocking more than the small minority of hate speech websites on Tor.

  1. When censorship is possible and routine, censorship is far more easily compelled.

See above.

Friend, I think this is naive. What makes you think that everyone will just decide to participate in this exactly as you want them to?

Some censorship is always necessary - such as to prevent the spread of ideas (like fascism) that threaten the very existence of institutions that are dedicated to free speech (like Tor). Do you think these fascists are going to let people run Tor if they got in power?

Of course, maybe you could try to design a censorship tool that didn't have these problems! But I think you'd find it pretty challenging. It's hard enough to build an anticensorship network.

I'm also going to edit your post to take out the link, and to reflect the feature you are requesting. If you believe what you say you believe, you should not link to nazi sites. They like it when you do that.

It's very frustrating to me that you're not seriously considering this, as evidenced by the fact that you added the obviously-sarcastic "but-its-the-good-kind-of-censorship" tag. Recently Tor project published a blog post which took a stand against hate speech. It's easy to see why - the rise of fascism in America and Europe is real and measurable, and has been terrifyingly visible recently. What, then, is Tor Project, the new home of these violent cretins, actually going to do about it? It's easy to nay-say and turn your nose up at things, but then, what real alternative is there? I can't understate the seriousness of this - all of us who value freedom and democracy need to take action against these fascists now, because once they take power, we certainly won't be able to use Tor to organize against them (see: China, for example, where Tor usage is only possible through the altruism of Tor bridge operators from other countries).

I think that your concerns have been taken very seriously, and you've received serious responses about the technical limitations, as well as threat modeling about the unintended consequences. If you still think that what you propose is possible without harming people who are already marginalized, then you need to explain clearly why you believe that to be true.

comment:21 Changed 5 weeks ago by catalyst

Keywords: but-its-the-good-kind-of-censorship removed

Removing this keyword because it can come across as sarcastic and dismissive. I think I understand the underlying sentiment and agree with it, but I think there are better ways to express it.

comment:22 Changed 5 weeks ago by cypherpunks

Stop wasting your time on obvious trolls who don't even bother to read the most basic of FAQs, or to swallow the most condensed explanations that you can possibly make up: "Tor is designed to defend human rights and privacy by preventing anyone from censoring things, even us", "Just because we build anticensorship tools that anyone can use, doesn't mean we don't think you're scum".

If the Tor relays start blocking the dailystormer, say in a perfect world 80% of them did this manual configuration (when many don't even make updates), then 1) it still can be reached since it's not 100%, 2) racist people can just set up more Tor relays that don't block the dailystormer.

Last edited 5 weeks ago by cypherpunks (previous) (diff)

comment:23 Changed 5 weeks ago by orthecreedence@…

I'm not a contributor, but a regular user of Tor. I am compelled to weigh in.

I think in a free society, censorship is a much greater evil than any one idea. In fact, censorship is one of the main tools used in a fascist regime. Consider that:

You are asking to fight fascism by employing fascistic tactics. This is the height of hypocrisy, and the ends DO NOT justify the means, nor do I believe it would even have the intended effect.

If fascism is really such a bad thing, then won't most people realize that? Won't they be able to read the arguments for and against and make up their own minds? Why is it ok to take that deciding power away from people? Because fascism is "evil?" Evil by your standards, but to others, a valid form of government. Who's right?

And now that it's suddenly ok to censor fascism, why not censor other things? Couldn't communism and socialism be considered "evil" considering how many regimes have used it as a tool for installing fascist governments? Is single payer health care evil? Some might say so. What about capitalism? Will sites exploring these ideas be censored as well based on the whims of those who participate in the network?

So now the Tor network becomes fragmented by people all censoring things they think shouldn't be said. Routes become a lot more complicated to calculate, and depending on your loaded route, certain websites just don't load.

Great job, you've weakened the entire network because you think "fascism is evil." You've taken a tool (NOT a tool for "good" or "bad" but a tool) and made it less useful for everyone because you want to force your own political viewpoints onto it.

Sounds like a really awful idea to me. Sure, fascism is bad. But censoring it via the Tor network is not just magnitudes worse, but in itself an evil act.

I don't want Tor to "protect" me from fascism. I want open access to all information without censorship.

comment:24 Changed 5 weeks ago by cypherpunks

I find it interesting how racism (of all things) is the reason you suggest implementing a mechanism for censorship in an anti-censorship tool. Does that mean you think child porn is a-okay? If the developers didn't add tools to remove onion sites hosting child porn, what makes you think they'd add it to remove racists?

I am glad this proposal has been rejected.

comment:25 Changed 4 weeks ago by cypherpunks

Ticketstarter, everything I wanna say here, is that censorship (you propose censorship, even if you claim it is not) is a sign of a fascist regime. So if you really want to oppose fascism, you should not propose censorship. Your ticket looks like bad trolling. And it is sad to see this kind of kidding in such a serious project bug tracker. Shame on you.

comment:26 Changed 3 weeks ago by mikeperry

This ticket is an interesting thought experiment. So interesting that I am interrupting my vacation to think about it. :)

Taking the long view here, if such a patch were written, it will only be a matter of time before trolls, nazis, or some other subculture decides to use it against others. In fact, if I'm someone who lives just to troll (*cough* weev *cough*), I'm basically waiting on the edge of my seat for this patch to get written (probably even while drooling a bit). I would just be dying to take the patch and advocate that people use it for censorship of a site that hosts content about $RANDOM_TOPIC_TANGENTIALLY_INVOLVING_JEWISH_CULTURE_SOMEHOW. It's just how that twisted motherfucker rolls.

So while it may be fun to think about doing something like this to ruin weev's and some Nazis day, really we should be considering any such patch as a red team exercise to strengthen the Tor network against further censorship. v3 hidden services will make such a thing harder because of shared randomness, but I bet there are still nasty issues wrt how clients react to HSDIRs that misbehave upon requests for descriptors (timeouts, corruption, stalling, and such). We should all be collectively looking for these issues, and fixing them ASAP so that clients are not impacted (or even delayed) when malicious relays behave in this way.

So, IMO: Patches welcome. So it goes. Let it play. And so on. There Is No Enemy Anywhere.

Last edited 3 weeks ago by mikeperry (previous) (diff)
Note: See TracTickets for help on using tickets.