Opened 2 years ago

Closed 2 years ago

#23272 closed defect (not a bug)

File group is wrong?

Reported by: yurivict271 Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.3.0.10
Severity: Normal Keywords: bsd
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Looking at db files:

# ls -l /var/db/tor/
total 23512
-rw------- 1 _tor _tor 18209 Jul 3 11:47 cached-certs
-rw------- 1 _tor _tor 2087391 Aug 18 14:37 cached-microdesc-consensus
-rw------- 1 _tor _tor 7966413 Aug 15 18:43 cached-microdescs
-rw------- 1 _tor _tor 1794414 Aug 18 14:37 cached-microdescs.new
-rw------- 1 _tor _tor 32 Aug 18 11:58 control_auth_cookie
-rw------- 1 _tor _tor 0 Aug 18 12:12 lock
-rw------- 1 _tor _tor 14061 Aug 18 15:04 state

Shouldn't all files except control_auth_cookie be owned by wheel:_tor instead? Only control_auth_cookie needs to be read by others.

FreeBSD 11.1

Child Tickets

Change History (6)

comment:1 Changed 2 years ago by yurivict271

Resolution: not a bug
Status: newclosed

comment:2 Changed 2 years ago by yurivict271

Resolution: not a bug
Status: closedreopened

comment:3 Changed 2 years ago by yurivict271

control_auth_cookie should be:
-rw-r----- 1 _tor _tor 32 Aug 18 11:58 control_auth_cookie

comment:4 Changed 2 years ago by catalyst

Component: - Select a componentCore Tor/Tor
Keywords: bsd added
Milestone: Tor: unspecified
Status: reopenedneeds_information

I think we might need a bit more information to make progress on this. Why do you expect the user/group ownerships to be that way? How are you starting tor? Is this the ports package or built from source? (I'm not personally very familiar with FreeBSD but someone else might be.)

I think control_auth_cookie will only be group-readable if you configure it to be.

comment:5 Changed 2 years ago by yurivict271

Ah, if this is configurable then this isn't a bug.

comment:6 Changed 2 years ago by yurivict271

Resolution: not a bug
Status: needs_informationclosed
Note: See TracTickets for help on using tickets.