Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#23282 closed enhancement (duplicate)

Add option to permanently block resizes of the Tor Browser's default window 1000x600 size

Reported by: cypherpunks Owned by: tbb-team
Priority: Very Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Add option to permanently block resizes of the Tor Browser's default window 1000x600 size

On low resolution laptops it's easy to screw up things when moving the window close to the top bar (on debian) and it gets automatically maximized (same thing may happen on other systems such as Windows 7).

I'm aware this wouldn't be your top priority for now given your current agenda and priorities so I put Very Low currently.

Child Tickets

Change History (5)

comment:1 Changed 13 months ago by gk

Resolution: worksforme
Status: newclosed

I guess you want to have an option to stop the resizing at all (not just to 1000x600 as it happens with your setup)? In that case extensions.torbutton.resize_new_windows on about:config should do the trick.

comment:2 Changed 13 months ago by cypherpunks

Resolution: worksforme
Status: closedreopened

Not OP, but it's a duplicate of #20129.

comment:3 Changed 13 months ago by cypherpunks

Status: reopenedneeds_information

Also dom.disable_window_move_resize looks worth enabling.

comment:4 in reply to:  2 Changed 13 months ago by gk

Resolution: duplicate
Status: needs_informationclosed

Replying to cypherpunks:

Not OP, but it's a duplicate of #20129.

Oh, yes, good catch. Thanks.

comment:5 in reply to:  3 Changed 13 months ago by gk

Replying to cypherpunks:

Also dom.disable_window_move_resize looks worth enabling.

I am not sure about that one. We had some discussion in #9881 and IIRC it did not look that appealing back then due to different browser behavior with that preference enabled.

Note: See TracTickets for help on using tickets.