Opened 2 years ago

Closed 2 years ago

#23299 closed defect (duplicate)

Crash when trying to save a PDF in Tor Browser

Reported by: teor Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-crash
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I was trying to save a PDF in Tor Browser and got this crash. I can't reproduce it:

Process:               firefox [47500]
Path:                  /Applications/TorBrowser.app/Contents/MacOS/firefox
Identifier:            org.torproject.torbrowser
Version:               7.0.4 (5217.2.2)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           firefox [47500]
User ID:               ...

Date/Time:             2017-08-23 ...
OS Version:            Mac OS X 10.12.6 (16G29)
Report Version:        12
Anonymous UUID:        ...

Sleep/Wake UUID:       ...

Time Awake Since Boot: 1400000 seconds
Time Since Wake:       160000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0:
--> 
    __TEXT                 00000001075ac000-00000001075af000 [   12K] r-x/rwx SM=COW  /Applications/TorBrowser.app/Contents/MacOS/firefox

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libmozglue.dylib              	0x00000001075b6190 mozalloc_abort(char const*) + 48

Thread 1:: Gecko_IOThread
0   libsystem_kernel.dylib        	0x00007fff8f779d96 kevent + 10
1   XUL                           	0x00000001085d4f7c 0x10818a000 + 4501372

Thread 2:: Socket Thread
0   libsystem_kernel.dylib        	0x00007fff8f778eb6 __select + 10
1   libnss3.dylib                 	0x00000001079a00a5 0x107800000 + 1704101

Thread 3:: JS Watchdog
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712

Thread 4:: JS Helper
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   XUL                           	0x000000010acb2d61 0x10818a000 + 45256033
3   ???                           	0x00000000434f4e44 0 + 1129270852

(duplicate threads)

Thread 12:
0   libsystem_kernel.dylib        	0x00007fff8f77134a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff8f770797 mach_msg + 55
2   XUL                           	0x000000010b274b0e 0x10818a000 + 51292942
3   ???                           	0x0000000000010000 0 + 65536

Thread 13:: Hang Monitor
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 14:: Timer
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50e3 PR_WaitCondVar + 227

Thread 15:: Cache2 I/O
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 16:: DataStorage
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

(duplicate threads)

Thread 18:: IPDL Background
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 19:: GMPThread
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 20:: Compositor
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   XUL                           	0x00000001085c7d18 0x10818a000 + 4447512
3   ???                           	0x8000000000000000 0 + 9223372036854775808

Thread 21:: ImgDecoder #1
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

(duplicate threads)

Thread 24:: ImageIO
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 25:: RunProcess
0   libsystem_kernel.dylib        	0x00007fff8f7793ee __wait4 + 10
1   XUL                           	0x0000000108238a5e 0x10818a000 + 715358

Thread 26:: DOM Worker
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 27:: URL Classifier
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 28:
0   libsystem_kernel.dylib        	0x00007fff8f77134a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff8f770797 mach_msg + 55
2   XUL                           	0x000000010b27499e 0x10818a000 + 51292574
3   libsystem_pthread.dylib       	0x00007fff8f863887 _pthread_start + 286
4   libsystem_pthread.dylib       	0x00007fff8f86308d thread_start + 13

Thread 29:: HTML5 Parser
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 30:: localStorage DB
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 31:: ImageBridgeChild
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   XUL                           	0x00000001085c7d18 0x10818a000 + 4447512
3   ???                           	0x8000000000000000 0 + 9223372036854775808

Thread 32:
0   libsystem_kernel.dylib        	0x00007fff8f77134a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff8f770797 mach_msg + 55
2   XUL                           	0x00000001085cf5d8 0x10818a000 + 4478424
3   libsystem_pthread.dylib       	0x00007fff8f863887 _pthread_start + 286
4   libsystem_pthread.dylib       	0x00007fff8f86308d thread_start + 13

Thread 33:: ProcessHangMonitor
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   XUL                           	0x00000001085c7d18 0x10818a000 + 4447512
3   ???                           	0x8000000000000000 0 + 9223372036854775808

Thread 34:: mozStorage #1
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

(duplicate threads)

Thread 36:: Proxy R~olution
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 37:: Cache I/O
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 38:: mozStorage #3
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 39:: com.apple.NSEventThread
0   libsystem_kernel.dylib        	0x00007fff8f77134a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff8f770797 mach_msg + 55
2   com.apple.CoreFoundation      	0x00007fff79a88874 __CFRunLoopServiceMachPort + 212
3   com.apple.CoreFoundation      	0x00007fff79a87cf1 __CFRunLoopRun + 1361
4   com.apple.CoreFoundation      	0x00007fff79a87544 CFRunLoopRunSpecific + 420
5   com.apple.AppKit              	0x00007fff776ccf02 _NSEventThread + 205
6   libsystem_pthread.dylib       	0x00007fff8f86393b _pthread_body + 180
7   libsystem_pthread.dylib       	0x00007fff8f863887 _pthread_start + 286
8   libsystem_pthread.dylib       	0x00007fff8f86308d thread_start + 13

Thread 40:: mozStorage #4
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

(duplicate threads)

Thread 43:: DOM Worker
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 44:
0   libsystem_kernel.dylib        	0x00007fff8f77134a mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff8f770797 mach_msg + 55
2   XUL                           	0x000000010b27499e 0x10818a000 + 51292574
3   libsystem_pthread.dylib       	0x00007fff8f863887 _pthread_start + 286
4   libsystem_pthread.dylib       	0x00007fff8f86308d thread_start + 13

Thread 45:: CVDisplayLink
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f864833 _pthread_cond_wait + 769
2   com.apple.CoreVideo           	0x00007fff7b161977 CVDisplayLink::waitUntil(unsigned long long) + 233
3   com.apple.CoreVideo           	0x00007fff7b161762 CVDisplayLink::runIOThread() + 520
4   libsystem_pthread.dylib       	0x00007fff8f86393b _pthread_body + 180
5   libsystem_pthread.dylib       	0x00007fff8f863887 _pthread_start + 286
6   libsystem_pthread.dylib       	0x00007fff8f86308d thread_start + 13

Thread 46:
0   libsystem_kernel.dylib        	0x00007fff8f77944e __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff8f86348e _pthread_wqthread + 1023
2   libsystem_pthread.dylib       	0x00007fff8f86307d start_wqthread + 13

(duplicate threads)

Thread 48:: StreamTrans #27
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712

Thread 49:
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 50:
0   libsystem_kernel.dylib        	0x00007fff8f77944e __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff8f863621 _pthread_wqthread + 1426
2   libsystem_pthread.dylib       	0x00007fff8f86307d start_wqthread + 13

Thread 51:: Storage I/O
0   libsystem_kernel.dylib        	0x00007fff8f778bf2 __psynch_cvwait + 10
1   libsystem_pthread.dylib       	0x00007fff8f8647fa _pthread_cond_wait + 712
2   libnss3.dylib                 	0x00000001079b50fd PR_WaitCondVar + 253

Thread 52:
0   libsystem_kernel.dylib        	0x00007fff8f77944e __workq_kernreturn + 10
1   libsystem_pthread.dylib       	0x00007fff8f86348e _pthread_wqthread + 1023
2   libsystem_pthread.dylib       	0x00007fff8f86307d start_wqthread + 13

Thread 53:

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x00000001075cd832  rbx: 0x00007fff985a0a20  rcx: 0x00000001075d1418  rdx: 0x0000000000012068
  rdi: 0x00007fff985a0048  rsi: 0x0000000000abe600  rbp: 0x00007fff985a0a20  rsp: 0x00007fff58651330
   r8: 0x0000000000000040   r9: 0x00007fff985a0040  r10: 0xffffffffffffffff  r11: 0x0000000000012068
  r12: 0x000000010b3bafce  r13: 0x499fb8522f0d00b9  r14: 0x000000000000012b  r15: 0x0000000000000003
  rip: 0x00000001075b6190  rfl: 0x0000000000010202  cr2: 0x0000000000000000
  
Logical CPU:     2
Error Code:      0x00000006
Trap Number:     14

Child Tickets

Change History (4)

comment:1 Changed 2 years ago by gk

Keywords: tbb-crash added
Status: newneeds_information

Did that happen with the built-in pdf viewer? Or did you get an external helper app warning dialog? If so, did it crash when clicking on a button?

comment:2 Changed 2 years ago by cypherpunks

Potentially duplicate of: #22610 waiting for confirmation :)

comment:3 in reply to:  1 Changed 2 years ago by teor

Replying to gk:

Did that happen with the built-in pdf viewer? Or did you get an external helper app warning dialog? If so, did it crash when clicking on a button?

It was open in the built-in viewer, I clicked on the "open in external app", because it had forms, and there was no warning dialog. I did get a download dialog, but the download didn't transfer anything. And then some time after, the app crashed.

comment:4 Changed 2 years ago by gk

Resolution: duplicate
Status: needs_informationclosed

Let's close this as a duplicate of #22471. I believe the underlying issue is the same. We are currently testing a fix for it in the alpha and hope to backport it soon.

Note: See TracTickets for help on using tickets.