Opened 2 years ago

Closed 2 years ago

#23308 closed enhancement (fixed)

prop224: Implement note_connection_attempt_succeeded() in the client code

Reported by: dgoulet Owned by: dgoulet
Priority: High Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs, prop224
Cc: Actual Points:
Parent ID: #23300 Points:
Reviewer: asn Sponsor: SponsorR-must

Description

#17242 has gone over many review rounds so implement this once we get it upstream.

This function should do the job that rend_client_note_connection_attempt_ended() does that is purging the hsdir request cache.

Child Tickets

Change History (3)

comment:1 Changed 2 years ago by dgoulet

Reviewer: asn
Status: assignedneeds_review

See branch: ticket23308_032_01.

I *think* it's the cleanest approach I could find. The problem is not that trivial for the edge connection identifier to keep the blinded key it has used when sending the fetch to the directory. The problem is that this whole chain is async and we don't pass the edge connection ident through the set of functions to fetch a descriptor.

Furthermore, the time period is also taken when the fetch is triggered so we can't really put that value in the edge conn identifier either.

So, middle ground is to try to purge for both time period.

I'm really open to a new solution if one could be cleaner but definitely passing the edge connection up to the fetch function would be messy and conditional to the context...

comment:2 Changed 2 years ago by asn

Status: needs_reviewmerge_ready

LGTM!

comment:3 Changed 2 years ago by nickm

Resolution: fixed
Status: merge_readyclosed

merged this

Note: See TracTickets for help on using tickets.