Opened 2 years ago

Closed 2 years ago

#23311 closed defect (fixed)

prop224: Spammy intro point logs in v2

Reported by: asn Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs, prop224
Cc: Actual Points:
Parent ID: #20657 Points: 0.3
Reviewer: Sponsor:

Description

With the #17242 branch, when I start an hsv2 service, there are good chances it will start spamming the logs like this:

Aug 21 14:59:02.000 [warn] Hidden service yfqspegde4a6pkt5 exceeded launch limit with 9 intro points in the last 31 seconds. Intro circuit launches are limited to 8 per 300 seconds.
Aug 21 14:59:02.000 [warn] Service configured in "/home/f/tmp/hsv2":
Aug 21 14:59:02.000 [warn]   Intro point 0 at [scrubbed]: circuit is open
Aug 21 14:59:02.000 [warn]   Intro point 1 at [scrubbed]: circuit is open
Aug 21 14:59:02.000 [warn]   Intro point 2 at [scrubbed]: circuit is waiting to see how other guards perform
Aug 21 14:59:02.000 [warn]   Intro point 3 at [scrubbed]: circuit is open
Aug 21 14:59:03.000 [warn] Hidden service yfqspegde4a6pkt5 exceeded launch limit with 9 intro points in the last 32 seconds. Intro circuit launches are limited to 8 per 300 seconds.
Aug 21 14:59:03.000 [warn] Service configured in "/home/f/tmp/hsv2":
Aug 21 14:59:03.000 [warn]   Intro point 0 at [scrubbed]: circuit is open
Aug 21 14:59:03.000 [warn]   Intro point 1 at [scrubbed]: circuit is open
Aug 21 14:59:03.000 [warn]   Intro point 2 at [scrubbed]: circuit is open
Aug 21 14:59:04.000 [warn] Hidden service yfqspegde4a6pkt5 exceeded launch limit with 9 intro points in the last 33 seconds. Intro circuit launches are limited to 8 per 300 seconds.
Aug 21 14:59:04.000 [warn] Service configured in "/home/f/tmp/hsv2":
Aug 21 14:59:04.000 [warn]   Intro point 0 at [scrubbed]: circuit is open
Aug 21 14:59:04.000 [warn]   Intro point 1 at [scrubbed]: circuit is open
Aug 21 14:59:04.000 [warn]   Intro point 2 at [scrubbed]: circuit is open
Aug 21 14:59:05.000 [warn] Hidden service yfqspegde4a6pkt5 exceeded launch limit with 9 intro points in the last 34 seconds. Intro circuit launches are limited to 8 per 300 seconds.
Aug 21 14:59:05.000 [warn] Service configured in "/home/f/tmp/hsv2":
Aug 21 14:59:05.000 [warn]   Intro point 0 at [scrubbed]: circuit is open
Aug 21 14:59:05.000 [warn]   Intro point 1 at [scrubbed]: circuit is open
Aug 21 14:59:05.000 [warn]   Intro point 2 at [scrubbed]: circuit is open
Aug 21 14:59:06.000 [warn] Hidden service yfqspegde4a6pkt5 exceeded launch limit with 9 intro points in the last 35 seconds. Intro circuit launches are limited to 8 per 300 seconds.
Aug 21 14:59:06.000 [warn] Service configured in "/home/f/tmp/hsv2":
Aug 21 14:59:06.000 [warn]   Intro point 0 at [scrubbed]: circuit is open
Aug 21 14:59:06.000 [warn]   Intro point 1 at [scrubbed]: circuit is open
Aug 21 14:59:06.000 [warn]   Intro point 2 at [scrubbed]: circuit is open

We need to figure out if this was caused by the prop224 patches and fix it if so.

Child Tickets

Change History (1)

comment:1 Changed 2 years ago by dgoulet

Resolution: fixed
Status: newclosed

Fixed by #22159. It has been rate limited and the actual limit has been changed to what was originally intended.

Note: See TracTickets for help on using tickets.