Opened 2 years ago

Closed 2 years ago

#23328 closed defect (worksforme)

prop224: Uninitialized hsdir indices if requesting onion before bootstrap completes

Reported by: asn Owned by:
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs, prop224
Cc: Actual Points:
Parent ID: #23300 Points: 0.3
Reviewer: Sponsor:

Description

Seems like Tor will attempt to fetch an HSv3 descriptor if we request an onion address before bootstrap completes. This causes uninitialized hsdir indices errors. We should probably delay HSv3 descriptor fetches until we have 100% bootstrapped:

Aug 25 15:27:31.380 [notice] Bootstrapped 80%: Connecting to the Tor network
Aug 25 15:27:31.859 [notice] Bootstrapped 85%: Finishing handshake with first hop
Aug 25 15:27:32.698 [warn] tor_bug_occurred_(): Bug: src/or/hs_common.c:1208: node_has_hsdir_index: Non-fatal assertion !(tor_mem_is_zero((const char*)node->hsdir_index->current, DIGEST256_LEN)) failed. (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.706 [warn] Bug: Non-fatal assertion !(tor_mem_is_zero((const char*)node->hsdir_index->current, DIGEST256_LEN)) failed in node_has_hsdir_index at src/or/hs_common.c:1208. Stack trace: (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.707 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(log_backtrace+0x42) [0x285df2] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.707 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(tor_bug_occurred_+0xb7) [0x29ed97] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.707 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(hs_get_responsible_hsdirs+0x4a8) [0x26a4e8] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.707 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(hs_client_refetch_hsdesc+0xbc) [0x26679c] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.707 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(connection_ap_handshake_rewrite_and_attach+0x37a) [0x2169ea] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.707 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(connection_edge_process_inbuf+0x1d0) [0x218080] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.708 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(+0x107ed8) [0x20fed8] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.708 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(+0x4e3d1) [0x1563d1] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.708 [warn] Bug:     /usr/lib/x86_64-linux-gnu/libevent-2.0.so.5(event_base_loop+0x7fc) [0x53613dc] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.708 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(do_main_loop+0x244) [0x157464] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.708 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(tor_main+0x1c35) [0x15acb5] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.708 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(main+0x19) [0x152bc9] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.708 [warn] Bug:     /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x623db45] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)
Aug 25 15:27:32.708 [warn] Bug:     /home/f/Computers/tor/mytor/src/or/tor(+0x4ac19) [0x152c19] (on Tor 0.3.2.0-alpha-dev e07b677bd9d557d2)

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by asn

Hmm, I haven't been getting this lately even when i request an onion before bootstrap completes.

comment:2 Changed 2 years ago by dgoulet

Resolution: worksforme
Status: newclosed

This whole hsdir logic is about to completely change in #23387. I'm closing this because we can't reproduce, we haven't seen it in a while and the code path there changed a lot in since this was opened.

Note: See TracTickets for help on using tickets.