Opened 9 years ago

Closed 9 years ago

#2333 closed defect (invalid)

net-proxy/tsocks-1.8_beta5-r5 segfaults if tor patch is used

Reported by: toralf Owned by:
Priority: Medium Milestone:
Component: Torify Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The origin of this bug report is here : https://bugs.gentoo.org/show_bug.cgi?id=347656

Gentoo forces tsocks to be build with a (so-called) USE flag, which means, that the tsocks sources are patched with tsocks-1.8b5-tordns1-gentoo-r1.patch.gz (attached). However this lets tsocks crash for ssh connections.

Child Tickets

Attachments (1)

tsocks-1.8b5-tordns1-gentoo-r1.patch.gz (19.6 KB) - added by toralf 9 years ago.
tor patch for tsocks

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by toralf

tor patch for tsocks

comment:1 Changed 9 years ago by arma

Component: - Select a componentTorify

That patch is obsolete.

In fact, we don't even recommend vanilla tsocks anymore.

Check out torsocks instead.

(Probably somebody should tell the gentoo people.)

comment:2 in reply to:  1 Changed 9 years ago by rransom

Replying to arma:

(Probably somebody should tell the gentoo people.)

The torify script included with Tor still relies on tsocks.

comment:3 Changed 9 years ago by arma

In Tor 0.2.1 it does, you're right.

But in 0.2.2 and later, we preferentially use torsocks if we can find it.

Should we backport the torify update to 0.2.1 then, to make tsocks more officially obsolete?

I'm under the impression not many people use torify. Or maybe I should phrase that as "I'm under the impression not many people should use torify." :/

comment:4 Changed 9 years ago by arma

In any case, if gentoo is shipping a tsocks with old patches, the fix for them should be to drop the patches from their tsocks package and also package torsocks. Trying to hack the old patches on tsocks isn't a good use of anybody's time, especially since that's exactly what torsocks did.

comment:5 Changed 9 years ago by toralf

Resolution: invalid
Status: newclosed

Ok, so Gentoo specific patch set issue - I'll close this ticket here.

Note: See TracTickets for help on using tickets.