Opened 10 months ago

Closed 3 months ago

#23356 closed defect (duplicate)

proxy-go starts using 100% CPU when network is disconnected

Reported by: dcf Owned by:
Priority: Medium Milestone:
Component: Obfuscation/Snowflake Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A power outage disconnected the network of a laptop on which I was running proxy-go. The laptop battery kept the computer running until the power came back on, but the network was still down. When I checked on it, the log was filled with 2.4 GB of

2017/08/29 10:02:33 error polling broker: Post https://snowflake-reg.appspot.com/proxy: dial tcp: lookup snowflake-reg.appspot.com on <dns server>:53: dial udp <dns server>:53: connect: network is unreachable
2017/08/29 10:02:33 error polling broker: Post https://snowflake-reg.appspot.com/proxy: dial tcp: lookup snowflake-reg.appspot.com on <dns server>:53: dial udp <dns server>:53: connect: network is unreachable
2017/08/29 10:02:33 error polling broker: Post https://snowflake-reg.appspot.com/proxy: dial tcp: lookup snowflake-reg.appspot.com on <dns server>:53: dial udp <dns server>:53: connect: network is unreachable

There were 11,879,088 of these messages over the course of about an hour (according to the log timestamps), so about 3,330 messages per second. I'm guessing the code was in a tight failure loop.

Child Tickets

Change History (1)

comment:1 Changed 3 months ago by dcf

Resolution: duplicate
Status: newclosed

This is really a duplicate of #25344.

Note: See TracTickets for help on using tickets.