Opened 10 months ago

Closed 5 months ago

#23406 closed defect (not a bug)

Sampled guards are not re-weighted when a new consensus arrives

Reported by: teor Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.3.x-final
Component: Core Tor/Tor Version: Tor: 0.3.0.1-alpha
Severity: Normal Keywords: path-selection, tor-guard
Cc: Actual Points:
Parent ID: #23318 Points: 1
Reviewer: Sponsor: SponsorV-can

Description

Replying to https://trac.torproject.org/projects/tor/ticket/23318#comment:5:

It's not only case when code bypassing limits, as noticed by pastly in IRC. Guard nodes weights only if new guard added by entry_guards_expand_sample. Sample guard or subsets never being re-weighted: once sampled non-Exit Guard will be used as Exit+Guard (if operator change it policy) by client.

This is probably the behaviour we want: re-weighting based on the latest consensus allows Guard operators to detect exactly when a client downloads the next consensus (because it would stop using that Guard).

That said, keeping old weights might allow attacks based on knowing the weightings in a really old consensus.

Child Tickets

Change History (3)

comment:1 Changed 9 months ago by nickm

Milestone: Tor: 0.3.2.x-finalTor: 0.3.3.x-final
Owner: set to nickm
Status: newaccepted

comment:2 Changed 8 months ago by nickm

Sponsor: SponsorV-can

comment:3 Changed 5 months ago by nickm

Resolution: not a bug
Status: acceptedclosed
Note: See TracTickets for help on using tickets.