Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#23448 closed defect (duplicate)

ECDH performance warning with LibreSSL

Reported by: svengo Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.0.10
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor 0.3.0.10 running with LibreSSL 2.5.5 (latest stable):

[notice] Tor 0.3.0.10 (git-c33db290a9d8d0f9) running on Linux with Libevent 2.1.8-stable, OpenSSL LibreSSL 2.5.5 and Zlib 1.2.11.
[notice] We were built to run on a 64-bit CPU, with OpenSSL 1.0.1 or later, but with a version of OpenSSL that apparently lacks accelerated support for the NIST P-224 and P-256 groups. Building openssl with such support (using the enable-ec_nistp_64_gcc_128 option when configuring it) would make ECDH much faster.

LibreSSL doesn't have this configure option and I don't think that there are any problems with ECDH.

Maybe its time to remove the warning?

Child Tickets

Change History (2)

comment:1 Changed 2 years ago by yawning

Resolution: duplicate
Status: newclosed

Duplicate of #23232

comment:2 Changed 2 years ago by gk

Component: - Select a componentCore Tor/Tor
Note: See TracTickets for help on using tickets.