#23454 closed defect (fixed)

stderr is missing from build logs

Reported by: boklm Owned by: boklm
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-rbm, TorBrowserTeam201709R
Cc: tbb-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In #23425 we redirected the output from runc start to /dev/null to avoid annoying messages saying "stdin: is not a tty". However this also removes stderr from build logs.

It seems the command producing the stdin: is not a tty message is the chown -R command from runc/remote_put, so we should only remove stderr from that part while keeping it for the runc command running the build script.

Child Tickets

Change History (4)

comment:1 Changed 19 months ago by boklm

Keywords: TorBrowserTeam201709R added; TorBrowserTeam201709 removed
Status: assignedneeds_review

comment:2 Changed 19 months ago by boklm

The stdin: is not a tty message while running the chown -R command seems to be caused by the mesg n command at the end of the /root/.profile file on Ubuntu. We don't have this message in the part where we are running the build script as this part is not run as root (and the mesg n is not present in users' .profile file)

comment:3 Changed 19 months ago by boklm

I pushed a new version of the patch adding a comment explaining why we hide stderr in that part:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_23454_v2

comment:4 Changed 19 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks, looks good to me. Applied to master (commit 75af4379125bcf3979f54b5773f1ced1c37eb9c6).

Note: See TracTickets for help on using tickets.