#23476 closed defect (worksforme)

buf_t is in kernel_types.h on macOS (and maybe BSD)

Reported by: teor Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points: 0.2
Reviewer: Sponsor:

Description

Let's consider using some other name?

Child Tickets

Change History (3)

comment:1 Changed 21 months ago by teor

Owner: set to nickm
Status: newassigned

Assigning so it stays in 0.3.2

comment:2 Changed 21 months ago by nickm

on IRC, teor said this is maybe an artifact of having a stale src/or/buffers.h . I'll try on my macos laptop and confirm.

comment:3 Changed 21 months ago by nickm

Resolution: worksforme
Status: assignedclosed

Okay; confirmed. I can't reproduce this in my OSX build environement.

(Please reopen if this is really happening)

Note: See TracTickets for help on using tickets.