Opened 2 years ago

Closed 17 months ago

#23489 closed enhancement (duplicate)

Enhance about:tor design

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: ux-team, ff60-esr
Cc: linda Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I think the UX team should consider ways to enhance the about:tor page design, preferably using the same design ideas for the upcoming torproject.org design refresh. It should also respect if possible Photon (Firefox' new upcoming UI) design guidelines: http://design.firefox.com/photon/

I'm putting the ff59-esr keyword since such change will at best be for the next ESR release, and since ff59-esr should also offer a new design as mentioned above, so it's also the perfect occasion to refresh the about:tor design.

Child Tickets

Change History (4)

comment:1 Changed 2 years ago by cypherpunks

One may even add an onboarding process at the first install, especially if the Tor Button changes in #23151 are implemented = to accustom the user to the new design.

FWIW Firefox 57 (and I assume 59 as well) has an onboarding process in about:home (Install Firefox Nightly to test it).

comment:2 Changed 2 years ago by linda

We agree that this is a great idea, and is on our list of things to work on. Our idea is to use that page to onboard users as well.

comment:3 Changed 23 months ago by gk

Keywords: ff60-esr added; ff59-esr removed

Firefox 60 is the new ESR.

comment:4 Changed 17 months ago by gk

Resolution: duplicate
Status: newclosed

That's a duplicate of #25695.

Note: See TracTickets for help on using tickets.