Opened 9 years ago

Closed 9 years ago

#2354 closed defect (fixed)

arm crash on e in first screen

Reported by: murble Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

built debian package from most recent svn trunk (r24038)

on a lenny machine with python-minimal
ii python-minimal 2.5.2-3
python -V
Python 2.5.2

press e and
the back trace is:

Traceback (most recent call last):

File "/usr/share/arm/starter.py", line 282, in <module>

interface.controller.startTorMonitor(time.time() - initTime, expandedEvents, paramstartup.blindModeEnabled?)

File "/usr/share/arm/interface/controller.py", line 1756, in startTorMonitor

curses.wrapper(drawTorMonitor, startTime, loggedEvents, isBlindMode)

File "/usr/lib/python2.5/curses/wrapper.py", line 44, in wrapper

return func(stdscr, *args, kwds)

File "/usr/share/arm/interface/controller.py", line 1075, in drawTorMonitor

eventsInput = panelscontrol?.getstr(0, 15)

File "/usr/share/arm/util/panel.py", line 362, in getstr

textbox = curses.textpad.Textbox(inputSubwindow, True)

TypeError: init() takes exactly 2 arguments (3 given)

Child Tickets

Change History (2)

comment:1 Changed 9 years ago by atagar

Status: newaccepted

The problem is that the flag for using a Textbox in insert mode was added in Python 2.6:
http://bugs.python.org/issue1048820

Before that the Textbox constructor only accepted one argument (the subwindow). Thanks for the bug report! I'll fix it tomorrow morning.

Cheers! -Damian

comment:2 Changed 9 years ago by atagar

Resolution: fixed
Status: acceptedclosed

Fix checked in (r24042) and double checked with murb that it's resolved the issue. Resolving.

Note: See TracTickets for help on using tickets.