Opened 18 months ago

Closed 5 months ago

#23559 closed defect (duplicate)

Extensions Last Updated date January 1, 2000

Reported by: cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TorBrowser 7.0.5 (based on Mozilla Firefox 52.3.0) (64-bit)
Linux (Ubuntu 16.04)

After extracting and loading a new TorBrowser instance, all extensions' Last Updated date is shown as January 1, 2000 (see screenshot).

about:addons -> Extensions -> More

This may be caused by the timestamps on the files in the xz, which are shown as 31 December 1999 19:00.

Child Tickets

Attachments (1)

tor_extensions_2k.png (71.2 KB) - added by cypherpunks 18 months ago.

Download all attachments as: .zip

Change History (3)

Changed 18 months ago by cypherpunks

Attachment: tor_extensions_2k.png added

comment:1 Changed 5 months ago by arma

Yeah, this isn't surprising -- Tor Browser gets built with the date of Jan 1 2000, so everybody has the same date on disk to start.

Is there a bug here? Anything to fix? Or should we close this ticket as "yes, we know, that's how it works"?

comment:2 Changed 5 months ago by gk

Resolution: duplicate
Status: newclosed

I think we should try to get this solved as an enhancement. But we can do so while working on #11506. So, duping this over to that bug.

Note: See TracTickets for help on using tickets.