Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#2356 closed defect (not a bug)

Clarification of the ReachableAddresses option

Reported by: anonym Owned by: arma
Priority: Medium Milestone: Tor: 0.2.2.x-final
Component: Core Tor/Tor Version: Tor: 0.2.1.26
Severity: Keywords: tor-bridge
Cc: anonym, amnesia@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by arma)

I have "ReachableAddresses reject *:*" in torrc and start Tor. Tor obviously cannot connect. Then I add a bridge through Vidalia, and, voila, Tor connects to the Tor network through the bridge, ignoring ReachableAddresses.

Is this expected behaviour? Are bridges exempt from the ReachableAddresses option? My reading of that option in the man page is that it should prevent ALL connections, bridges included. Is this a bug, an error in the man page, or an error in my head?

Child Tickets

Change History (10)

comment:1 Changed 9 years ago by nickm

Milestone: Tor: 0.2.2.x-final

We should figure out what we want to do here by 0.2.2.x, and document it, and document the current behavior if they differ. If we don't like the current behavior, we should see about fixing #2357 too.

comment:2 Changed 9 years ago by T(A)ILS developers

Cc: amnesia@… added

comment:3 Changed 9 years ago by arma

Component: Tor ClientTor Bridge
Description: modified (diff)

comment:4 Changed 8 years ago by arma

Owner: set to arma
Priority: normalmajor
Status: newassigned

comment:5 Changed 8 years ago by arma

When I reproduce all of this leaving Vidalia out of the loop, it works as expected:

Apr 28 18:50:43.884 [notice] Bridge at '188.x.x.x:443' isn't reachable by our firewall policy. Skipping.

When I use Vidalia to set the bridge, it looks like Vidalia is doing a resetconf on our reachableaddresses config option.

Before:

getconf reachableaddresses
250 ReachableAddresses=reject *:*

After:

getconf reachableaddresses
250 ReachableAddresses

To be fair, I bet your Vidalia settings don't have "My firewall only lets me connect to certain ports" clicked. So you have told Vidalia that you can reach all addresses. Not totally crazy that it would correct your Tor to match your Vidalia settings.

When I click the "My firewall only lets me connect to certain ports" and set it to 1, I get the behavior you wanted.

comment:6 Changed 8 years ago by arma

Priority: majornormal

(Ok to close?)

comment:7 in reply to:  6 Changed 8 years ago by anonym

Replying to arma:

When I use Vidalia to set the bridge, it looks like Vidalia is doing a resetconf on our reachableaddresses config option.

Aah. My experience with Vidalia controlling Tor (but not starting it) was that all Vidalia options that the user hasn't set explicitly are set according to the corresponding options in torrc. I suppose that behaviour isn't as consistent as I thought so my assumption doesn't hold in general.

As a side note, perhaps it's worth making Vidalia's options handling vs the options in torrc more consistent?

Replying to arma:

(Ok to close?)

Yeah, case closed.

comment:8 Changed 8 years ago by nickm

Resolution: not a bug
Status: assignedclosed

Replying to arma:

(Ok to close?)

Yeah, case closed.


So closing. Please re-open if there was something going on that I missed here.

comment:9 Changed 7 years ago by nickm

Keywords: tor-bridge added

comment:10 Changed 7 years ago by nickm

Component: Tor BridgeTor
Note: See TracTickets for help on using tickets.